aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-05-22 16:40:06 +0300
committerKhem Raj <raj.khem@gmail.com>2020-05-22 13:42:43 -0700
commit41a79745cb9ccd144e83aebb0a01d733d4502f3c (patch)
tree13dc96770b4fa8513b92c64ef5eac2a1438d0295 /meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
parentae52d8c3fc9e93a72e7482506af36cc0bbe8f0d1 (diff)
downloadmeta-openembedded-41a79745cb9ccd144e83aebb0a01d733d4502f3c.tar.gz
python3-webcolors: Upgrade 1.8.1 -> 1.11.1
Upgrade to release 1.11.1. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb b/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
new file mode 100644
index 0000000000..e567e0ba28
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=25b90379a52351261c51272e7923d240"
+
+SRC_URI[md5sum] = "54d28a7c80b3e4d974ec2fee86768be9"
+SRC_URI[sha256sum] = "76f360636957d1c976db7466bc71dcb713bb95ac8911944dffc55c01cb516de6"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}_class-target = "\
+ ${PYTHON_PN}-stringold \
+"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"