aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-03 17:05:14 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-06 10:26:59 -0700
commit6fbfe8e8fce5b6e8bf535304766631668d30f8be (patch)
tree342ae6696bb0d836e5f180986aa85856a1f8cd11 /meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb
parentd3e5cd25bcb1c55a9b480a689aa4279532139cf7 (diff)
downloadmeta-openembedded-6fbfe8e8fce5b6e8bf535304766631668d30f8be.tar.gz
python3-ujson: Upgrade 3.0.0 -> 3.1.0
Upgrade to release 3.1.0: - PEP 489 Multi Phase Init support - PyPy3 test fixes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb b/meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb
new file mode 100644
index 0000000000..ef57b2a1fc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson_3.1.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
+
+SRC_URI[md5sum] = "875ac729018f3cac786d471422306fa8"
+SRC_URI[sha256sum] = "00bda1de275ed6fe81817902189c75dfd156b4fa29b44dc1f4620775d2f50cf7"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytz \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"