aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 09:28:46 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-04 07:22:16 -0700
commit248316fd60de06f2cae38ce6092dbd1b112d7f4b (patch)
treea8f3f7853be95d67ad14c90df292f5de625d070b /meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb
parenteb2910278699fc1e14c4668eaa8e83be5e302ce5 (diff)
downloadmeta-openembedded-248316fd60de06f2cae38ce6092dbd1b112d7f4b.tar.gz
python-twitter: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb b/meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb
index c2e4d2ebd3..78f66a4435 100644
--- a/meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twitter_3.8.0.bb
@@ -1,3 +1,19 @@
-require python-twitter.inc
+SUMMARY = "Twitter for Python"
+DESCRIPTION = "Python module to support twitter API"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8f702b489acb6863cec8b261a55931d8"
+
+SRC_URI[md5sum] = "8aeff278b7cefcd384c65929bc921e2c"
+SRC_URI[sha256sum] = "8abd828ba51a85a2b5bb7373715d6d3bb32d18ac624e3a4db02e4ef8ab48316b"
+
+PYPI_PACKAGE = "tweepy"
+
inherit pypi setuptools3
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-six \
+"