aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:34 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit41e4d12b90545407f6141d8483164401f6274ce6 (patch)
tree977aafb1a1f1470560e1ba325e85c4c6f0a5be5e /meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
parent4ecf8c7780105f155800098de7418c6ee47be388 (diff)
downloadmeta-openembedded-41e4d12b90545407f6141d8483164401f6274ce6.tar.gz
python-sqlparse: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb30
1 files changed, 28 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
index a646ac6486..1aef28be03 100644
--- a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
@@ -1,3 +1,29 @@
-inherit setuptools3
-require python-sqlparse.inc
+DESCRIPTION = "Non-validating SQL parser module"
+HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
+
+SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
+ file://run-ptest \
+ "
+
+SRC_URI[md5sum] = "423047887a3590b04dd18f8caf843a2f"
+SRC_URI[sha256sum] = "e162203737712307dfe78860cc56c8da8a852ab2ee33750e33aeadf38d12c548"
+
+export BUILD_SYS
+export HOST_SYS
+
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
BBCLASSEXTEND = "native nativesdk"