aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-redis_2.10.6.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:20:53 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit0c128f6a343dfdb92c201e1cff08d8646fd3d0da (patch)
tree01e62107bd22397c57f762cce1121a27b8d10507 /meta-python/recipes-devtools/python/python3-redis_2.10.6.bb
parent7ab3029b1f489369074bbcf1a6b066969d28e53a (diff)
downloadmeta-openembedded-0c128f6a343dfdb92c201e1cff08d8646fd3d0da.tar.gz
python-redis: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-redis_2.10.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-redis_2.10.6.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-redis_2.10.6.bb b/meta-python/recipes-devtools/python/python3-redis_2.10.6.bb
index b192ed8725..3acc2fdaea 100644
--- a/meta-python/recipes-devtools/python/python3-redis_2.10.6.bb
+++ b/meta-python/recipes-devtools/python/python3-redis_2.10.6.bb
@@ -1,2 +1,14 @@
+SUMMARY = "Python client for Redis key-value store"
+DESCRIPTION = "The Python interface to the Redis key-value store."
+HOMEPAGE = "http://github.com/andymccurdy/redis-py"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=51d9ad56299ab60ba7be65a621004f27"
+
+SRC_URI[md5sum] = "048348d8cfe0b5d0bba2f4d835005c3b"
+SRC_URI[sha256sum] = "a22ca993cea2962dbb588f9f30d0015ac4afcc45bee27d3978c0dbe9e97c6c0f"
+
inherit pypi setuptools3
-require python-redis.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+"