aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-26 16:20:08 -0300
committerKhem Raj <raj.khem@gmail.com>2020-05-28 12:36:49 -0700
commit2f65b7197355a4a0791cf84bd9c49a8d9eef760b (patch)
treef03743400c6065feaf27a7c3619b269a02bbea16 /meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
parente116260648d65398af6077b62e7780ab81253be1 (diff)
downloadmeta-openembedded-2f65b7197355a4a0791cf84bd9c49a8d9eef760b.tar.gz
python3-pytest: Update 5.3.5 -> 5.4.2
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb b/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
new file mode 100644
index 0000000000..9258c21caf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Simple powerful testing with python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
+
+SRC_URI[sha256sum] = "eb2b5e935f6a019317e455b6da83dd8650ac9ffd2ee73a7b657a30873d67a698"
+
+SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch "
+
+inherit update-alternatives pypi setuptools3
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pluggy \
+ ${PYTHON_PN}-py \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-atomicwrites \
+ ${PYTHON_PN}-importlib-metadata \
+ ${PYTHON_PN}-pathlib2 \
+ ${PYTHON_PN}-wcwidth \
+ ${PYTHON_PN}-more-itertools \
+ ${PYTHON_PN}-packaging \
+"
+
+ALTERNATIVE_${PN} += "py.test pytest"
+
+NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
+ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
+
+ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
+ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
+
+BBCLASSEXTEND = "native nativesdk"