aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-24 13:35:09 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:23:15 -0700
commit9c5ac93936d30558803e766bb4539460a43cafd2 (patch)
tree2656153e1f6b7378209c69678a032e1fe8fceb50 /meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb
parent76b83194b31ca57790fdffb43c81c8cb0131f527 (diff)
downloadmeta-openembedded-9c5ac93936d30558803e766bb4539460a43cafd2.tar.gz
python3-pytest-metadata: Upgrade 1.9.0 -> 1.10.0
Upgrade to release 1.10.0: - Compatible with pytest-xdist 1.22.3+, now including 2.0+ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb
new file mode 100644
index 0000000000..70cc98f294
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-metadata_1.10.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "pytest-metadata is a plugin that allowed for accessing pytest metadata"
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
+
+SRC_URI[sha256sum] = "b7e6e0a45adacb17a03a97bf7a2ef60cc1f4e172bcce9732ce5e814191932315"
+SRC_URI[md5sum] = "4fcf9764e6210c4555411fce8109e7cd"
+
+PYPI_PACKAGE = "pytest-metadata"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"