aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pint_0.14.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-02 13:48:15 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:19:53 -0700
commit89d91f8fc5bd0e43d0e6071cddb14dd0a1b223bb (patch)
tree19736f646a817cda401f0c44980f48ae7218e2e3 /meta-python/recipes-devtools/python/python3-pint_0.14.bb
parentdd88a3efc2be320b903be284816e364d70e11e94 (diff)
downloadmeta-openembedded-89d91f8fc5bd0e43d0e6071cddb14dd0a1b223bb.tar.gz
python3-pint: Upgrade 0.13 -> 0.14
Upgrade to release 0.14: - Changes required to support Pint-Pandas 0.1 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.14.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.14.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.14.bb b/meta-python/recipes-devtools/python/python3-pint_0.14.bb
new file mode 100644
index 0000000000..8e16304768
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.14.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Physical quantities Python module"
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi ptest setuptools3
+
+SRC_URI[md5sum] = "e5e409806bc82f518230117b30ae23ed"
+SRC_URI[sha256sum] = "9aa450ebb9d722ed03fa9a450104cfd16c479b49f862d547c6f77320de597f72"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}