aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipy_1.00.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-06-15 22:38:05 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:56:43 -0700
commitcefcd956607ddb0c93003eda979b6cf81137b78d (patch)
tree19a1616c2753022fbfb8e51d70a8681f952ccb1c /meta-python/recipes-devtools/python/python3-ipy_1.00.bb
parent3bfde64d32c89579e9eb93bd048044907105d354 (diff)
downloadmeta-openembedded-cefcd956607ddb0c93003eda979b6cf81137b78d.tar.gz
python3-ipy: Enable ptest
-Consolidate into a single file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipy_1.00.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy_1.00.bb34
1 files changed, 32 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipy_1.00.bb b/meta-python/recipes-devtools/python/python3-ipy_1.00.bb
index ea6a1055a8..14931546e9 100644
--- a/meta-python/recipes-devtools/python/python3-ipy_1.00.bb
+++ b/meta-python/recipes-devtools/python/python3-ipy_1.00.bb
@@ -1,2 +1,32 @@
-inherit setuptools3
-require python-ipy.inc
+SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks"
+DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
+in a fashion similar to perl's Net::IP and friends. The IP class allows \
+a comfortable parsing and handling for most notations in use for IPv4 \
+and IPv6 Addresses and Networks."
+SECTION = "devel/python"
+HOMEPAGE = "https://github.com/autocracy/python-ipy"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
+
+SRC_URI[md5sum] = "1a90c68174234672241a7e60c7ea0fb9"
+SRC_URI[sha256sum] = "2f2bf658a858d43868d8a4352b3889cf78c66e2ce678b300dcf518c9149ba621"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test/
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
+}
+
+PYPI_PACKAGE = "IPy"
+
+BBCLASSEXTEND = "native"