aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-08 12:46:54 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-10 09:35:26 -0700
commit5037cd86c2ef5e3c058987721b258d8a8b8320de (patch)
tree6ea3ae590ae3e3acd9882d1cb954050ee0fc046a /meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb
parent80f1562a941436d54f8fcd66fe90c6f39304ac37 (diff)
downloadmeta-openembedded-5037cd86c2ef5e3c058987721b258d8a8b8320de.tar.gz
python3-imageio: Upgrade 2.8.0 -> 2.9.0
Upgrade to release 2.9.0: - More robust loading of FEI SEM data. - Fix webcam not working on Win10. - Add a few standard images useful to 3D visualization. - The timeout used in HTTP requests can now be set with an environment variable. - The DICOM plugin can now used gdcm for compressed transfer formats. - Better support for itk/sitk plugins. - Test coverage and CI for ARM. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb b/meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb
new file mode 100644
index 0000000000..fbe5e2c975
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-imageio_2.9.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Python library that provides an easy interface to read and \
+write a wide range of image data, including animated images, video, \
+volumetric data, and scientific formats."
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7b9bbbb543b6af3e6b53f9b7fb68f71d"
+
+
+SRC_URI[md5sum] = "d22757338542e3742a335cea6210e419"
+SRC_URI[sha256sum] = "52ddbaeca2dccf53ba2d6dec5676ca7bc3b2403ef8b37f7da78b7654bb3e10f0"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "python3-numpy python3-pillow"