aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-21 14:16:03 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-22 22:17:00 -0700
commit4fbb740722d37a9665c516dfca2e6c60174df24d (patch)
tree95f04fb5ba687a56cef4e83ba0bca61e97381df9 /meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb
parent7622e9d2e339bafe8eb57b3d18aa353a8f8dcdcf (diff)
downloadmeta-openembedded-4fbb740722d37a9665c516dfca2e6c60174df24d.tar.gz
python3-humanize: Upgrade 3.0.1 -> 3.1.0
Upgrade to release 3.1.0: - Declare support for Python 3.9 - testing/docs: Include doctests in testing - Allow custom "now" in naturaldelta and naturaltime - Represent with a zero if the delta is too small Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb b/meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb
new file mode 100644
index 0000000000..43b882cb84
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanize_3.1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python humanize utilities"
+HOMEPAGE = "http://github.com/jmoiron/humanize"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
+
+SRC_URI[md5sum] = "bde0a033cf200f2874e6e3fc860bed48"
+SRC_URI[sha256sum] = "fd3eb915310335c63a54d4507289ecc7b3a7454cd2c22ac5086d061a3cbfd592"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-setuptools-scm-native \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"