aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-12 18:12:28 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-13 14:07:47 -0800
commit115144fce9d97143bcb77ee4bdab5b19e61f6f82 (patch)
tree38c854368c417f720a33f65fa11d6927992a971c /meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
parent0b7e50f7be5d639250f05a694272977216e7f7dd (diff)
downloadmeta-openembedded-115144fce9d97143bcb77ee4bdab5b19e61f6f82.tar.gz
python3-grpcio: Upgrade to 1.27.1
Merge inc file into bb, there are no other users of it Delete gettid patch, fixed differenty upstream Add code to use cross compiler in setup.py Define GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY so it does not use SYS_clock_gettime syscalls since it does not work when 64bit time_t is used on 32bit arches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
new file mode 100644
index 0000000000..bc2b70cf87
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Google gRPC"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS += "${PYTHON_PN}-protobuf"
+
+SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
+ file://ppc-boringssl-support.patch \
+ file://riscv64_support.patch \
+"
+SRC_URI[md5sum] = "ccaf4e7eb4f031d926fb80035d193b98"
+SRC_URI[sha256sum] = "a899725d34769a498ecd3be154021c4368dd22bdc69473f6ec46779696f626c4"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+"
+
+inherit setuptools3
+inherit pypi
+
+export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
+
+CLEANBROKEN = "1"
+
+BBCLASSEXTEND = "native nativesdk"