aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-12-26 16:40:28 +0800
committerKhem Raj <raj.khem@gmail.com>2023-12-29 09:04:21 -0800
commit8c2c816bc45543697f25dc6386ec79989f01cc52 (patch)
tree34f8ab2c2658d2a7a4f906f80271fa22c5092aa7 /meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
parent0fdda9232f61755318da961104a7077f7bff49dd (diff)
downloadmeta-openembedded-8c2c816bc45543697f25dc6386ec79989f01cc52.tar.gz
python3-distro: upgrade 1.8.0 -> 1.9.0
Changelog: ========== -Refactor distro.info() method to return an InfoDict -Ignore the file '/etc/board-release' -Ignore the file '/etc/ec2_version' -Run Python 3.6 on Ubuntu 20.04 for CI and bump isort -Test on modern versions of CPython and PyPy and macOS -Add support for ALT Linux Server 10.1 distribution -Add Debian Testing to the tests -Update archlinux resource for tests Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-distro_1.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-distro_1.9.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
new file mode 100644
index 0000000000..a342432a6b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Distro is an OS platform information API"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+PYPI_PACKAGE = "distro"
+
+SRC_URI[sha256sum] = "2fa77c6fd8940f116ee1d6b94a2f90b13b5ea8d019b98bc8bafdcabcdd9bdbed"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"