aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-04 12:28:01 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-08 13:57:34 -0700
commit736030a9aaa9b5d03e6d7b1b9bee609aa9e1bcc7 (patch)
tree4396273380e2437f99342d44617f90f32def9467 /meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
parent4b83eab28ec20424308c9e02f7e551a97eff8fda (diff)
downloadmeta-openembedded-736030a9aaa9b5d03e6d7b1b9bee609aa9e1bcc7.tar.gz
python3-decorator: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb21
1 files changed, 19 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb b/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
index 844cbdc9a9..23d0cf2181 100644
--- a/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-decorator_4.4.2.bb
@@ -1,2 +1,19 @@
-inherit setuptools3
-require python-decorator.inc
+SUMMARY = "Python decorator utilities"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
+
+SRC_URI[md5sum] = "d83c624cce93e6bdfab144821b526e1d"
+SRC_URI[sha256sum] = "e3a62f0520172440ca0dcc823749319382e377f37f140a0b99ef45fecb84bfe7"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-stringold \
+ "