aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb
diff options
context:
space:
mode:
authorJonathan Richardson <jonathan.richardson@broadcom.com>2020-04-08 15:18:35 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-08 18:16:12 -0700
commitd28cb81c5fa266cfa3a1b9b35afe6d925da7ee61 (patch)
treee8f01ffa1e3a8f99c416166369e4bcf479b5cd2d /meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb
parent44abef2c1dcfb3d7b0b43e36a6fa17839867a481 (diff)
downloadmeta-openembedded-d28cb81c5fa266cfa3a1b9b35afe6d925da7ee61.tar.gz
configshell-fb: Add initial version 1.1.28
configshell-fb is a python library that provides a framework for building simple but nice CLI-based applications. Signed-off-by: Jonathan Richardson <jonathan.richardson@broadcom.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb b/meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb
new file mode 100644
index 0000000000..2d9ec079a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-configshell-fb_1.1.28.bb
@@ -0,0 +1,16 @@
+SUMMARY = "A Python library for building configuration shells"
+DESCRIPTION = "configshell-fb is a Python library that provides a framework for \
+building simple but nice CLI-based applications. This runs with Python 2 and \
+2to3 is run by setup.py to run on Python 3."
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI = "git://github.com/open-iscsi/configshell-fb.git;protocol=https;branch=master"
+SRCREV = "da8f0cef114e7343a7ae96ff1db7c8c574f819be"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += "python3-modules python3-fcntl python3-six"