aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-23 12:51:31 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-25 10:21:22 -0700
commit780d7bd435a568fac6b94a5096a4b6d1e58f4862 (patch)
tree3704683de3beb0163839e4f4de27b7dcc0586393 /meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb
parent2fc0494071d57a00d808fc734b6dcbc35acdf16a (diff)
downloadmeta-openembedded-780d7bd435a568fac6b94a5096a4b6d1e58f4862.tar.gz
python3-configparser: Upgrade 4.0.2 -> 5.0.0
Add toml-native as dependency. Upgrade to release 5.0.0: - Require Python 3.6 or later. For Python 2.6-3.5, use configparser < 5 (selection should be automatic when installed using pip 9 from PyPI). The 4.x line remains supported for bug fixes but will no longer be updated for future releases. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb b/meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb
new file mode 100644
index 0000000000..6b2af125fb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-configparser_5.0.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "This module provides the ConfigParser class which implements a basic configuration language which provides a structure similar to what's found in Microsoft Windows INI files."
+SECTION = "devel/python"
+HOMEPAGE = "https://docs.python.org/3/library/configparser.html"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=23f9ad5cad3d8cc0336e2a5d8a87e1fa"
+
+SRC_URI[md5sum] = "558114054aa5610365df1b34d3fea349"
+SRC_URI[sha256sum] = "2ca44140ee259b5e3d8aaf47c79c36a7ab0d5e94d70bd4105c03ede7a20ea5a1"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-toml-native"
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"