aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/utouch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-30 00:29:33 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:28:28 +0200
commit8acb143f454d84192a809e1ff785932b9d16e7e4 (patch)
treeb89808a03a76f0df55cac79072e606cf322e195a /meta-oe/recipes-support/utouch
parent50c14d2535046e4d5bc5a00f4a3d171d9c5a053e (diff)
downloadmeta-openembedded-8acb143f454d84192a809e1ff785932b9d16e7e4.tar.gz
utouch: Fix build on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/utouch')
-rw-r--r--meta-oe/recipes-support/utouch/files/0001-include-sys-stat.h-for-fixing-build-issue-on-musl.patch29
-rw-r--r--meta-oe/recipes-support/utouch/utouch-frame_git.bb4
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/utouch/files/0001-include-sys-stat.h-for-fixing-build-issue-on-musl.patch b/meta-oe/recipes-support/utouch/files/0001-include-sys-stat.h-for-fixing-build-issue-on-musl.patch
new file mode 100644
index 0000000000..f3c8eeb418
--- /dev/null
+++ b/meta-oe/recipes-support/utouch/files/0001-include-sys-stat.h-for-fixing-build-issue-on-musl.patch
@@ -0,0 +1,29 @@
+From 08b17ec505e09e8f5a4d73ffc3aa61561ec2e0da Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 30 Mar 2017 00:27:54 -0700
+Subject: [PATCH] include sys/stat.h for fixing build issue on musl
+
+error: field has incomplete
+ type 'struct stat'
+ struct stat fs;
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tools/utouch-frame-test-mtdev.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tools/utouch-frame-test-mtdev.c b/tools/utouch-frame-test-mtdev.c
+index 5253320..2032af4 100644
+--- a/tools/utouch-frame-test-mtdev.c
++++ b/tools/utouch-frame-test-mtdev.c
+@@ -30,6 +30,7 @@
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <sys/stat.h>
+ #include "common-defs.h"
+
+ struct frame_test {
+--
+2.12.1
+
diff --git a/meta-oe/recipes-support/utouch/utouch-frame_git.bb b/meta-oe/recipes-support/utouch/utouch-frame_git.bb
index 6ec566ddb2..39d46af8e9 100644
--- a/meta-oe/recipes-support/utouch/utouch-frame_git.bb
+++ b/meta-oe/recipes-support/utouch/utouch-frame_git.bb
@@ -10,7 +10,9 @@ DEPENDS += "mtdev utouch-evemu"
inherit autotools pkgconfig
SRC_URI = "git://bitmath.org/git/frame.git;protocol=http \
- file://remove-man-page-creation.patch"
+ file://remove-man-page-creation.patch \
+ file://0001-include-sys-stat.h-for-fixing-build-issue-on-musl.patch \
+ "
SRCREV = "95363d5a1f7394d71144bf3b408ef4e6db4350fc"
PV = "1.1.2+git${SRCPV}"