aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nmon/nmon_16m.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-30 02:14:48 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-01 05:45:17 -0700
commit9c9c02d434a8ea7a2dd0dadc0ec130aec37f1ff3 (patch)
tree229b24f6055dfab19532070496931ac9610d7f8d /meta-oe/recipes-support/nmon/nmon_16m.bb
parenta1ac306208bb9f56fc6e311bd9ff87c46dc2182f (diff)
downloadmeta-openembedded-9c9c02d434a8ea7a2dd0dadc0ec130aec37f1ff3.tar.gz
nmon: Upgrade to 16m
Fix compile with ncurses 6.3+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/nmon/nmon_16m.bb')
-rw-r--r--meta-oe/recipes-support/nmon/nmon_16m.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/nmon/nmon_16m.bb b/meta-oe/recipes-support/nmon/nmon_16m.bb
new file mode 100644
index 0000000000..723da85d0f
--- /dev/null
+++ b/meta-oe/recipes-support/nmon/nmon_16m.bb
@@ -0,0 +1,30 @@
+SUMMARY = "nmon performance monitor"
+HOMEPAGE = "http://nmon.sf.net"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://Documentation.txt;md5=dbb13658cf55d687c4f2ff771a696d4a"
+DEPENDS = "ncurses"
+DEPENDS:append:libc-musl = " bsd-headers"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nmon/lmon${PV}.c;name=lmon \
+ ${SOURCEFORGE_MIRROR}/nmon/Documentation.txt;name=doc \
+ file://0001-lmon16g.c-Adjust-system-headers.patch \
+ file://0001-Fix-a-lot-of-Werror-format-security-errors-with-mvpr.patch \
+ "
+SRC_URI[lmon.sha256sum] = "2bed4d45fdfdf1d1387ec91e139c04975d5f838e3e0d53c0fe2d803a707e5fc1"
+SRC_URI[doc.sha256sum] = "1f7f83afe62a7210be5e83cd24157adb854c14599efe0b377a7ecca933869278"
+
+CFLAGS += "-D JFS -D GETUSER -Wall -D LARGEMEM"
+LDFLAGS += "-ltinfo -lncursesw -lm"
+ASNEEDED:pn-nmon = ""
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} lmon${PV}.c -o nmon
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 nmon ${D}${bindir}
+}