aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mcelog_159.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2018-07-08 19:37:20 -0700
committerKhem Raj <raj.khem@gmail.com>2018-07-09 08:38:53 -0700
commitb0cfa32993e301112a443cb11d17ca2c2d5857fa (patch)
tree036dfa92f82c40fa465a5f8837288f12d624abab /meta-oe/recipes-support/mcelog/mcelog_159.bb
parente65b1c4ebbbf2174125e7c659b908dd0f46c4509 (diff)
downloadmeta-openembedded-b0cfa32993e301112a443cb11d17ca2c2d5857fa.tar.gz
mcelog: Upgrade to 159
Licence-Update: * mcelog.org link changed to https://www.mcelog.org * Add the package version overridden support as below: By default mcelog reports its version as the git tag. This can be overridden by setting up a .os_release file in the source directory. A build system could write the OS version to this file to mark the binary. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mcelog_159.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_159.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_159.bb b/meta-oe/recipes-support/mcelog/mcelog_159.bb
new file mode 100644
index 0000000000..236ad7d007
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog_159.bb
@@ -0,0 +1,35 @@
+SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
+DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
+and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
+and should run on all Linux systems that need error handling."
+HOMEPAGE = "http://mcelog.org/"
+SECTION = "System Environment/Base"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
+ file://run-ptest \
+"
+
+SRCREV = "2ed5cc0489d20cbffdc6d2e08b1fe49973f0ee34"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep ptest
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
+ sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
+ sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
+}
+
+RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"