aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2017-11-16 00:29:09 +0800
committerArmin Kuster <akuster808@gmail.com>2017-11-19 13:41:58 -0800
commit5c79363f3f48575500de8e514f1f36be7c8ef494 (patch)
treee15fba84953404a9f00b442bc0b02fec12d98225 /meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch
parentdafa2929e137e57e821e96b27d8880b5c8a293f1 (diff)
downloadmeta-openembedded-5c79363f3f48575500de8e514f1f36be7c8ef494.tar.gz
freerdp: Update to 2.0.0
1) Upgrade freerdp from 1.2.5 to 2.0.0. 2) Delete two patches for they are included in 2.0.0. 0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch 0003-add-missing-define.patch 3) Add one patch 0001-Fix-gstreamer-1.0-detection.patch to fix the do_configure problem: | -- Finding required feature XRandR for X11 randr (X11 randr extension) | -- Found XRANDR: /yocto/work001/fnst/zrq/community/build_master/tmp/work/i586-poky-linux/freerdp/2.0.0+gitrAUTOINC+1648deb435-r0/recipe-sysroot/usr/lib/libXrandr.so | CMake Error at channels/tsmf/client/gstreamer/CMakeLists.txt:21 (message): | GStreamer library not found, but required for TSMF module. 4) Modify the do_install directory from winpr/tools/makecert/cli/ to winpr/tools/makecert-cli/ Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch')
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch
new file mode 100644
index 0000000000..a567cba925
--- /dev/null
+++ b/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch
@@ -0,0 +1,27 @@
+From 368989526c32cdf9d680a397fede3cb773fa2609 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 28 Jul 2017 16:31:41 -0400
+Subject: [PATCH] Fix gstreamer-1.0 detection
+
+Upstream State: Backport
+
+---
+ cmake/FindGStreamer_1_0.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/FindGStreamer_1_0.cmake b/cmake/FindGStreamer_1_0.cmake
+index 3aa8fc6..6fbc0ec 100644
+--- a/cmake/FindGStreamer_1_0.cmake
++++ b/cmake/FindGStreamer_1_0.cmake
+@@ -59,7 +59,7 @@ macro(FIND_GSTREAMER_COMPONENT _component_prefix _pkgconfig_name _library)
+
+ string(REGEX MATCH "(.*)>=(.*)" _dummy "${_pkgconfig_name}")
+ if ("${CMAKE_MATCH_2}" STREQUAL "")
+- pkg_check_modules(PC_${_component_prefix} "${_pkgconfig_name} >= ${GStreamer_FIND_VERSION}")
++ pkg_check_modules(PC_${_component_prefix} "${_pkgconfig_name} >= ${GSTREAMER_1_0_MINIMUM_VERSION}")
+ else ()
+ pkg_check_modules(PC_${_component_prefix} ${_pkgconfig_name})
+ endif ()
+--
+2.7.4
+