aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2017-11-16 00:29:09 +0800
committerArmin Kuster <akuster808@gmail.com>2017-11-19 13:41:58 -0800
commit5c79363f3f48575500de8e514f1f36be7c8ef494 (patch)
treee15fba84953404a9f00b442bc0b02fec12d98225 /meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch
parentdafa2929e137e57e821e96b27d8880b5c8a293f1 (diff)
downloadmeta-openembedded-5c79363f3f48575500de8e514f1f36be7c8ef494.tar.gz
freerdp: Update to 2.0.0
1) Upgrade freerdp from 1.2.5 to 2.0.0. 2) Delete two patches for they are included in 2.0.0. 0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch 0003-add-missing-define.patch 3) Add one patch 0001-Fix-gstreamer-1.0-detection.patch to fix the do_configure problem: | -- Finding required feature XRandR for X11 randr (X11 randr extension) | -- Found XRANDR: /yocto/work001/fnst/zrq/community/build_master/tmp/work/i586-poky-linux/freerdp/2.0.0+gitrAUTOINC+1648deb435-r0/recipe-sysroot/usr/lib/libXrandr.so | CMake Error at channels/tsmf/client/gstreamer/CMakeLists.txt:21 (message): | GStreamer library not found, but required for TSMF module. 4) Modify the do_install directory from winpr/tools/makecert/cli/ to winpr/tools/makecert-cli/ Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch')
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch
deleted file mode 100644
index d5f648568f..0000000000
--- a/meta-oe/recipes-support/freerdp/freerdp/0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From bea27fd919b64ee8d97996409e279e1e83d13594 Mon Sep 17 00:00:00 2001
-From: Jean-Louis Dupond <jean-louis@dupond.be>
-Date: Sun, 4 Oct 2015 18:17:33 +0200
-Subject: [PATCH] FindGStreamer_1_0: fix build failure for new gstreamer
- versions
-
----
- cmake/FindGStreamer_1_0.cmake | 30 +++++++++++++++---------------
- 1 file changed, 15 insertions(+), 15 deletions(-)
-
-diff --git a/cmake/FindGStreamer_1_0.cmake b/cmake/FindGStreamer_1_0.cmake
-index f7bf990..3aa8fc6 100644
---- a/cmake/FindGStreamer_1_0.cmake
-+++ b/cmake/FindGStreamer_1_0.cmake
-@@ -53,17 +53,17 @@ set(GSTREAMER_1_0_MINIMUM_VERSION 1.0.5)
- # Helper macro to find a Gstreamer plugin (or Gstreamer itself)
- # _component_prefix is prepended to the _INCLUDE_DIRS and _LIBRARIES variables (eg. "GSTREAMER_1_0_AUDIO")
- # _pkgconfig_name is the component's pkg-config name (eg. "gstreamer-1.0", or "gstreamer-video-1.0").
--# _header is the component's header, relative to the gstreamer-1.0 directory (eg. "gst/gst.h").
- # _library is the component's library name (eg. "gstreamer-1.0" or "gstvideo-1.0")
--macro(FIND_GSTREAMER_COMPONENT _component_prefix _pkgconfig_name _header _library)
-+macro(FIND_GSTREAMER_COMPONENT _component_prefix _pkgconfig_name _library)
- # FIXME: The QUIET keyword can be used once we require CMake 2.8.2.
-- pkg_check_modules(PC_${_component_prefix} ${_pkgconfig_name})
-
-- find_path(${_component_prefix}_INCLUDE_DIRS
-- NAMES ${_header}
-- HINTS ${PC_${_component_prefix}_INCLUDE_DIRS} ${PC_${_component_prefix}_INCLUDEDIR}
-- PATH_SUFFIXES gstreamer-1.0
-- )
-+ string(REGEX MATCH "(.*)>=(.*)" _dummy "${_pkgconfig_name}")
-+ if ("${CMAKE_MATCH_2}" STREQUAL "")
-+ pkg_check_modules(PC_${_component_prefix} "${_pkgconfig_name} >= ${GStreamer_FIND_VERSION}")
-+ else ()
-+ pkg_check_modules(PC_${_component_prefix} ${_pkgconfig_name})
-+ endif ()
-+ set(${_component_prefix}_INCLUDE_DIRS ${PC_${_component_prefix}_INCLUDE_DIRS})
-
- find_library(${_component_prefix}_LIBRARIES
- NAMES ${_library} gstreamer_android
-@@ -78,8 +78,8 @@ endmacro()
- # 1.1. Find headers and libraries
- set(GLIB_ROOT_DIR ${GSTREAMER_1_0_ROOT_DIR})
- find_package(Glib REQUIRED)
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0 gstreamer-1.0 gst/gst.h gstreamer-1.0)
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_BASE gstreamer-base-1.0 gst/gst.h gstbase-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0 gstreamer-1.0 gstreamer-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_BASE gstreamer-base-1.0 gstbase-1.0)
-
- # 1.2. Check Gstreamer version
- if (GSTREAMER_1_0_INCLUDE_DIRS)
-@@ -110,11 +110,11 @@ endif ()
- # 2. Find Gstreamer plugins
- # -------------------------
-
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_APP gstreamer-app-1.0 gst/app/gstappsink.h gstapp-1.0)
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_AUDIO gstreamer-audio-1.0 gst/audio/audio.h gstaudio-1.0)
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_FFT gstreamer-fft-1.0 gst/fft/gstfft.h gstfft-1.0)
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_PBUTILS gstreamer-pbutils-1.0 gst/pbutils/pbutils.h gstpbutils-1.0)
--FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_VIDEO gstreamer-video-1.0 gst/video/video.h gstvideo-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_APP gstreamer-app-1.0 gstapp-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_AUDIO gstreamer-audio-1.0 gstaudio-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_FFT gstreamer-fft-1.0 gstfft-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_PBUTILS gstreamer-pbutils-1.0 gstpbutils-1.0)
-+FIND_GSTREAMER_COMPONENT(GSTREAMER_1_0_VIDEO gstreamer-video-1.0 gstvideo-1.0)
-
- # ------------------------------------------------
- # 3. Process the COMPONENTS passed to FIND_PACKAGE
---
-2.6.4
-