aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-27 17:27:24 -0500
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commitb0081e82068da054b7dc977576918b1fa702d0c1 (patch)
treebd28331af13ef3b965aac743aa4415661eefd2cb /meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb
parentff3e8417c6907c4c645fd38ba3d77f7e5ef3b475 (diff)
downloadmeta-openembedded-b0081e82068da054b7dc977576918b1fa702d0c1.tar.gz
dos2unix: update to version 7.4.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb')
-rw-r--r--meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb b/meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb
new file mode 100644
index 0000000000..8d3c578d0d
--- /dev/null
+++ b/meta-oe/recipes-support/dos2unix/dos2unix_7.4.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Convert text file line endings between CRLF and LF"
+DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
+unix2dos to convert plain text files in DOS or Mac format to Unix \
+format and vice versa."
+HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
+SECTION = "support"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=1b78fca784db24f4a40e30b300787f3f"
+
+SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix"
+
+# Release 7.4.0
+SRCREV = "1182533bde3c1fe65be2ead465e87671faa2c027"
+
+S = "${WORKDIR}/git/dos2unix"
+
+inherit gettext perlnative
+
+# The dos2unix NLS relies on po4a-native, while po4a recipe is
+# provided by meta-perl layer, so make it optional here, you
+# need have meta-perl in bblayers.conf before enabling nls in
+# PACKAGECONFIG.
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
+
+EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
+EXTRA_OEMAKE_class-native = "ENABLE_NLS="
+
+do_install () {
+ oe_runmake DESTDIR="${D}${base_prefix}" install
+}
+
+BBCLASSEXTEND = "native nativesdk"