aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lvgl
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval.ext@huawei.com>2022-09-06 11:37:54 +0200
committerKhem Raj <raj.khem@gmail.com>2022-09-06 08:43:34 -0700
commit8d75eff6af0fd6ccf8a45b5c98c4a0194e292a2f (patch)
treefb29f88bcb125c462a25591eefe0461b9fbb79d3 /meta-oe/recipes-graphics/lvgl
parent5a02e200ff8b01df33d7cf1f56af54e8a90e49bc (diff)
downloadmeta-openembedded-8d75eff6af0fd6ccf8a45b5c98c4a0194e292a2f.tar.gz
lvgl: Add dialog-lvgl recipe as demo example
This example was written just to validate lvgl on wayland, Feel free to get inspiration from. Origin: https://github.com/astrolabe-coop/meta-openembedded Forwarded: https://github.com/openembedded/meta-openembedded/pull/601 Relate-to: https://git.ostc-eu.org/rzr/dialog-lvgl/-/issues/5 Relate-to: https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/ Signed-off-by: Philippe Coval <philippe.coval.ext@huawei.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lvgl')
-rw-r--r--meta-oe/recipes-graphics/lvgl/dialog-lvgl_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/dialog-lvgl_git.bb b/meta-oe/recipes-graphics/lvgl/dialog-lvgl_git.bb
new file mode 100644
index 0000000000..7e24c51f28
--- /dev/null
+++ b/meta-oe/recipes-graphics/lvgl/dialog-lvgl_git.bb
@@ -0,0 +1,29 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+# SPDX-License-Identifier: MIT
+
+SRC_URI = "gitsm://git.ostc-eu.org/rzr/dialog-lvgl;destsuffix=${S};protocol=https;nobranch=1"
+SRCREV = "5d2121457a6988c97cacb0790594440693fc3d29"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8ce0a84e5276f01364119c873b712c4f"
+AUTHOR = "Philippe Coval <philippe.coval.ext@huawei.com>"
+
+DEPENDS += "lvgl"
+DEPENDS += "lv-drivers"
+
+SUMMARY = "Basic UI utility to be used in scripts"
+DESCRIPTION = "Inspired by ncurses' dialog, implemented using LVGL"
+HOMEPAGE = "https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/"
+
+REQUIRED_DISTRO_FEATURES = "wayland"
+
+inherit pkgconfig
+inherit features_check
+
+EXTRA_OEMAKE += "sysroot=${RECIPE_SYSROOT}"
+EXTRA_OEMAKE += "DESTDIR=${D}"
+EXTRA_OEMAKE += "lvgl_driver=wayland"
+
+do_install() {
+ oe_runmake install
+}