aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/ostree
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-05-03 19:23:52 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-03 21:24:55 -0700
commitce3b9b7626522cb1d252b20ecae1fe811e6eb679 (patch)
tree8e22c4e1296f35716b05bf605f0be7d062cfcfdc /meta-oe/recipes-extended/ostree
parent7e5aaedea9dcab59251a781204a476998551ab0f (diff)
downloadmeta-openembedded-ce3b9b7626522cb1d252b20ecae1fe811e6eb679.tar.gz
ostree: fix build without gobject-introspection-data
* add --disable-introspection to UNKNOWN_CONFIGURE_OPT_IGNORE to fix: http://errors.yoctoproject.org/Errors/Details/702779/ ERROR: QA Issue: ostree: configure was passed unrecognised options: --disable-introspection [unknown-configure-option] * add glib-2.0-native to DEPENDS to fix: http://errors.yoctoproject.org/Errors/Details/702787/ glib-mkenums \ --template ../libostree-2023.2/src/libostree/ostree-enumtypes.h.template \ ../libostree-2023.2/src/libostree/ostree-fetcher.h > src/libostree/ostree-enumtypes.h.tmp && mv src/libostree/ostree-enumtypes.h.tmp src/libostree/ostree-enumtypes.h /bin/bash: line 2: glib-mkenums: command not found make: *** [Makefile:9990: src/libostree/ostree-enumtypes.h] Error 127 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/ostree')
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2023.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2023.2.bb b/meta-oe/recipes-extended/ostree/ostree_2023.2.bb
index 2990122959..7eeb77474f 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2023.2.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2023.2.bb
@@ -9,6 +9,7 @@ LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
DEPENDS = " \
+ glib-2.0-native \
glib-2.0 \
e2fsprogs \
libcap \
@@ -28,6 +29,8 @@ S = "${WORKDIR}/libostree-${PV}"
inherit autotools bash-completion gobject-introspection github-releases gtk-doc manpages pkgconfig ptest-gnome systemd
+UNKNOWN_CONFIGURE_OPT_IGNORE = "--disable-introspection --enable-introspection"
+
# Workaround compile failure:
# |../git/src/libotutil/zbase32.c:37:1: error: function returns an aggregate [-Werror=aggregate-return]
# so remove -Og and use -O2 as workaround