aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-04-08 21:28:44 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-21 13:03:09 +0200
commit6d8574da9b40c8860e6b530cc840ba55fa8ed0b1 (patch)
treec955b415c50970577b7005901ef32c7866473442 /meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
parent9882169d240529162378f5c4f8f00023d450cfd0 (diff)
downloadmeta-openembedded-6d8574da9b40c8860e6b530cc840ba55fa8ed0b1.tar.gz
serialcheck: add version 1.0.0
Simple serial tester Usage (as explained in Readme.txt, part of ${PN}-doc package): - Create a random file. dd if=/dev/urandom of=binary count=1 bs=4096 - Copy the random file to both nodes. - Start the test receiving node: serialcheck -d /dev/ttyS0 -f binary -m r -l 10 sending node: serialcheck -d /dev/ttyUSB0 -f binary -m t -l 10 Start the receiving side before the sending side. This will transfer the "binary" file 10 times and the other side will expect the file 10 times. Once the program completes both sides should write something similar to: | Needed 0 reads 1 writes loops 10 / 10 | cts: 0 dsr: 0 rng: 0 dcd: 0 rx: 0 tx: 40960 frame 0 ovr 0 par: 0 brk: 0 buf_ovrr: 0 and in error case the receive side: Needed 20 reads 0 writes Oh oh, inconsistency at pos 2273 (0x8e1). Original sample: 000008b0: 28 b2 18 c9 ec b5 2c b3 3a a1 29 b1 fc 27 20 7f (.....,.:.)..' . 000008c0: 42 f8 d5 cb d8 52 ec b5 c8 76 d3 4b d2 57 44 6a B....R...v.K.WDj 000008d0: 40 81 6a 82 27 fd 8d 50 84 70 bc 24 6b 3d 88 fd @.j.'..P.p.$k=.. 000008e0: 9f ac 78 a4 76 9b f9 1c 74 2c d6 79 22 60 c5 de ..x.v...t,.y"`.. 000008f0: 02 9c fb 52 21 4b 40 6f 80 69 2e 80 df 12 ba a0 ...R!K@o.i...... 00000900: 75 57 d5 22 33 c0 f3 bc 94 f8 aa 22 9d 02 59 20 uW."3......"..Y Received sample: 000008b0: 28 b2 18 c9 ec b5 2c b3 3a a1 29 b1 fc 27 20 7f (.....,.:.)..' . 000008c0: 42 f8 d5 cb d8 52 ec b5 c8 76 d3 4b d2 57 44 6a B....R...v.K.WDj 000008d0: 40 81 6a 82 27 fd 8d 50 84 70 bc 24 6b 3d 88 fd @.j.'..P.p.$k=.. 000008e0: 9f 00 ac 78 a4 76 9b f9 1c 74 2c d6 79 22 60 c5 ...x.v...t,.y"`. 000008f0: de 02 9c fb 52 21 4b 40 6f 80 69 2e 80 df 12 ba ....R!K@o.i..... 00000900: a0 75 57 d5 22 33 c0 f3 bc 94 f8 aa 22 9d 02 59 .uW."3......"..Y loops 54878 / 4294967295 cts: 0 dsr: 0 rng: 0 dcd: 0 rx: 224792017 tx: 223379456 frame 0 ovr 1 par: 0 brk: 0 buf_ovrr: 0 Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb')
-rw-r--r--meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb b/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
new file mode 100644
index 0000000000..98324e816a
--- /dev/null
+++ b/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Application to verify operation of serial ports"
+HOMEPAGE = "http://git.breakpoint.cc/cgit/bigeasy/serialcheck.git/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://git.breakpoint.cc/bigeasy/serialcheck.git \
+ file://0001-Add-option-to-enable-internal-loopback.patch \
+ file://0002-Restore-original-loopback-config.patch"
+
+SRCREV = "63854a2d0c0129efab132ec328a75279e013fb84"
+
+S = "${WORKDIR}/git"
+
+CFLAGS_prepend = "-Wall -Wextra -Wno-sign-compare -Wno-pointer-sign "
+
+do_install() {
+ install -d ${D}${bindir}
+ install ${S}/serialcheck ${D}${bindir}
+ install -d ${D}${docdir}/${BP}
+ install ${S}/Readme.txt ${D}${docdir}/${BP}
+}
+
+BBCLASSEXTEND = "nativesdk"