aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-28 13:24:12 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-01 09:06:56 -0800
commite82c489191feb88f800a25edec66741a0a0443c6 (patch)
tree8e896dd30d14acb2fb0c349d2b43531217076839 /meta-networking/recipes-devtools
parent8b8bfbcadf188cd5b234358590764e20d03d7861 (diff)
downloadmeta-openembedded-e82c489191feb88f800a25edec66741a0a0443c6.tar.gz
python3-scapy: Define custom PYPA_WHEEL
Standard defaults are not able to guess it right, so aid it a bit Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-networking/recipes-devtools')
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
index d318c27c5a..3a1f102dc9 100644
--- a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
+++ b/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
@@ -25,6 +25,8 @@ S = "${WORKDIR}/git"
UPSTREAM_CHECK_COMMITS = "1"
inherit setuptools3 ptest
+PIP_INSTALL_PACKAGE = "scapy"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-*-*.whl"
do_install:append() {
mv ${D}${bindir}/scapy ${D}${bindir}/scapy3