aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-12-15 08:52:36 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-18 22:17:22 -0800
commit026721909a6f512ef75348c5f0b0b37c65e3b86a (patch)
treed730b09473be693f98d1ccd66dd9b609304bc641 /meta-multimedia
parentd595b18e4691967fb5b699e9272f916d769a28d7 (diff)
downloadmeta-openembedded-026721909a6f512ef75348c5f0b0b37c65e3b86a.tar.gz
gstd: correctly delete files in do_install
gstd always installs these in /usr, so root_prefix would work only if usrmerge is in DISTRO_FEATURES. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
index cabbf2cc11..87792491ae 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
@@ -20,9 +20,9 @@ GTKDOC_MESON_OPTION = "enable-gtk-doc"
inherit meson pkgconfig gettext gtk-doc python3native python3-dir python3targetconfig
do_install:append() {
- rmdir ${D}${root_prefix}${localstatedir}/run/${BPN} ${D}${root_prefix}${localstatedir}/run \
- ${D}${root_prefix}${localstatedir}/log/${BPN} ${D}${root_prefix}${localstatedir}/log \
- ${D}${root_prefix}${localstatedir}
+ rmdir ${D}${exec_prefix}${localstatedir}/run/${BPN} ${D}${exec_prefix}${localstatedir}/run \
+ ${D}${exec_prefix}${localstatedir}/log/${BPN} ${D}${exec_prefix}${localstatedir}/log \
+ ${D}${exec_prefix}${localstatedir}
rm -f ${D}${bindir}/gst-client ${D}${bindir}/gstd-client
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d