aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-05-09 14:36:31 +0100
committerKhem Raj <raj.khem@gmail.com>2023-05-09 17:27:51 -0700
commit293af818724cbcc789682f12c8df8e4d3017fde4 (patch)
treea0237691662530269167f83868f902c089890e5a /meta-filesystems
parent5f64e51e5e945fa41f6447192144b5b36456b45b (diff)
downloadmeta-openembedded-293af818724cbcc789682f12c8df8e4d3017fde4.tar.gz
libisoburn: add new recipe
libisoburn is the library and command-line tool (xorriso) that can construct ISO-9660 images and write them to physical media. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/burnia/libisoburn_1.5.4.bb27
-rw-r--r--meta-filesystems/recipes-filesystems/packageconfigs/packagegroup-meta-filesystems.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/burnia/libisoburn_1.5.4.bb b/meta-filesystems/recipes-filesystems/burnia/libisoburn_1.5.4.bb
new file mode 100644
index 0000000000..f263b51350
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/burnia/libisoburn_1.5.4.bb
@@ -0,0 +1,27 @@
+SUMMARY = "library and tool to create and burn ISO-9660 images"
+HOMEPAGE = "https://libburnia-project.org/"
+
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88 \
+ file://COPYRIGHT;md5=43cfe25a7e4a65f722d6253fa0649bb1"
+
+SRC_URI = "http://files.libburnia-project.org/releases/libisoburn-${PV}.tar.gz"
+SRC_URI[sha256sum] = "2d89846d43880f17fa591c53b3bea42ffb803628e4e630c680fc2c9184f79132"
+
+DEPENDS = "libisofs libburn"
+# This replaces the xorriso recipe
+PROVIDES += "xorriso"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-pkg-check-modules"
+
+do_install:append() {
+ # This is a proof-of-concept UI using Tk, don't ship it
+ rm -f ${D}${bindir}/xorriso-tcltk
+}
+
+PACKAGE_BEFORE_PN = "xorriso"
+FILES:xorriso = "${bindir}"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-filesystems/recipes-filesystems/packageconfigs/packagegroup-meta-filesystems.bb b/meta-filesystems/recipes-filesystems/packageconfigs/packagegroup-meta-filesystems.bb
index c4e0a39e6b..361972a45b 100644
--- a/meta-filesystems/recipes-filesystems/packageconfigs/packagegroup-meta-filesystems.bb
+++ b/meta-filesystems/recipes-filesystems/packageconfigs/packagegroup-meta-filesystems.bb
@@ -20,6 +20,7 @@ RDEPENDS:packagegroup-meta-filesystems = "\
ifuse \
libisofs \
libburn \
+ libisoburn \
logfsprogs \
fuse-exfat \
owfs \