aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.sphinx
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.sphinx')
-rw-r--r--doc/Makefile.sphinx20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/Makefile.sphinx b/doc/Makefile.sphinx
new file mode 100644
index 000000000..933c77ee5
--- /dev/null
+++ b/doc/Makefile.sphinx
@@ -0,0 +1,20 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line, and also
+# from the environment for the first two.
+SPHINXOPTS ?=
+SPHINXBUILD ?= sphinx-build
+SOURCEDIR = .
+BUILDDIR = _build
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: help Makefile.sphinx
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile.sphinx
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)