aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bblayers
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:45 +0000
commit3b45c479de8640f92dd1d9f147b02e1eecfaadc8 (patch)
treeba0d71bdd8028442fd06002dc09e66ddf8291f6d /lib/bblayers
parent3cb0d1c78b4c2e4f251a59b86c8da583828ad08b (diff)
downloadbitbake-3b45c479de8640f92dd1d9f147b02e1eecfaadc8.tar.gz
bitbake: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bblayers')
-rw-r--r--lib/bblayers/action.py2
-rw-r--r--lib/bblayers/common.py2
-rw-r--r--lib/bblayers/layerindex.py8
-rw-r--r--lib/bblayers/query.py10
4 files changed, 11 insertions, 11 deletions
diff --git a/lib/bblayers/action.py b/lib/bblayers/action.py
index 739ae27b9..cf9470427 100644
--- a/lib/bblayers/action.py
+++ b/lib/bblayers/action.py
@@ -180,7 +180,7 @@ build results (as the layer priority order has effectively changed).
if first_regex:
# Find the BBFILES entries that match (which will have come from this conf/layer.conf file)
- bbfiles = str(self.tinfoil.config_data.getVar('BBFILES', True)).split()
+ bbfiles = str(self.tinfoil.config_data.getVar('BBFILES')).split()
bbfiles_layer = []
for item in bbfiles:
if first_regex.match(item):
diff --git a/lib/bblayers/common.py b/lib/bblayers/common.py
index b10fb4cea..98515ced4 100644
--- a/lib/bblayers/common.py
+++ b/lib/bblayers/common.py
@@ -12,7 +12,7 @@ class LayerPlugin():
def tinfoil_init(self, tinfoil):
self.tinfoil = tinfoil
- self.bblayers = (self.tinfoil.config_data.getVar('BBLAYERS', True) or "").split()
+ self.bblayers = (self.tinfoil.config_data.getVar('BBLAYERS') or "").split()
layerconfs = self.tinfoil.config_data.varhistory.get_variable_items_files('BBFILE_COLLECTIONS', self.tinfoil.config_data)
self.bbfile_collections = {layer: os.path.dirname(os.path.dirname(path)) for layer, path in layerconfs.items()}
diff --git a/lib/bblayers/layerindex.py b/lib/bblayers/layerindex.py
index 10ad718eb..013e952f3 100644
--- a/lib/bblayers/layerindex.py
+++ b/lib/bblayers/layerindex.py
@@ -151,7 +151,7 @@ class LayerIndexPlugin(ActionPlugin):
def do_layerindex_fetch(self, args):
"""Fetches a layer from a layer index along with its dependent layers, and adds them to conf/bblayers.conf.
"""
- apiurl = self.tinfoil.config_data.getVar('BBLAYERS_LAYERINDEX_URL', True)
+ apiurl = self.tinfoil.config_data.getVar('BBLAYERS_LAYERINDEX_URL')
if not apiurl:
logger.error("Cannot get BBLAYERS_LAYERINDEX_URL")
return 1
@@ -173,8 +173,8 @@ class LayerIndexPlugin(ActionPlugin):
return 1
ignore_layers = []
- for collection in self.tinfoil.config_data.getVar('BBFILE_COLLECTIONS', True).split():
- lname = self.tinfoil.config_data.getVar('BBLAYERS_LAYERINDEX_NAME_%s' % collection, True)
+ for collection in self.tinfoil.config_data.getVar('BBFILE_COLLECTIONS').split():
+ lname = self.tinfoil.config_data.getVar('BBLAYERS_LAYERINDEX_NAME_%s' % collection)
if lname:
ignore_layers.append(lname)
@@ -225,7 +225,7 @@ class LayerIndexPlugin(ActionPlugin):
printedlayers.append(dependency)
if repourls:
- fetchdir = self.tinfoil.config_data.getVar('BBLAYERS_FETCH_DIR', True)
+ fetchdir = self.tinfoil.config_data.getVar('BBLAYERS_FETCH_DIR')
if not fetchdir:
logger.error("Cannot get BBLAYERS_FETCH_DIR")
return 1
diff --git a/lib/bblayers/query.py b/lib/bblayers/query.py
index ee1e7c8a1..29491163c 100644
--- a/lib/bblayers/query.py
+++ b/lib/bblayers/query.py
@@ -62,7 +62,7 @@ are overlayed will also be listed, with a " (skipped)" suffix.
# factor - however, each layer.conf is free to either prepend or append to
# BBPATH (or indeed do crazy stuff with it). Thus the order in BBPATH might
# not be exactly the order present in bblayers.conf either.
- bbpath = str(self.tinfoil.config_data.getVar('BBPATH', True))
+ bbpath = str(self.tinfoil.config_data.getVar('BBPATH'))
overlayed_class_found = False
for (classfile, classdirs) in classes.items():
if len(classdirs) > 1:
@@ -114,7 +114,7 @@ skipped recipes will also be listed, with a " (skipped)" suffix.
def list_recipes(self, title, pnspec, show_overlayed_only, show_same_ver_only, show_filenames, show_multi_provider_only, inherits):
if inherits:
- bbpath = str(self.tinfoil.config_data.getVar('BBPATH', True))
+ bbpath = str(self.tinfoil.config_data.getVar('BBPATH'))
for classname in inherits:
classfile = 'classes/%s.bbclass' % classname
if not bb.utils.which(bbpath, classfile, history=False):
@@ -158,7 +158,7 @@ skipped recipes will also be listed, with a " (skipped)" suffix.
logger.plain("%s:", pn)
logger.plain(" %s %s%s", layer.ljust(20), ver, skipped)
- global_inherit = (self.tinfoil.config_data.getVar('INHERIT', True) or "").split()
+ global_inherit = (self.tinfoil.config_data.getVar('INHERIT') or "").split()
cls_re = re.compile('classes/')
preffiles = []
@@ -319,12 +319,12 @@ NOTE: .bbappend files can impact the dependencies.
ignore_layers = (args.ignore or '').split(',')
pkg_fn = self.tinfoil.cooker_data.pkg_fn
- bbpath = str(self.tinfoil.config_data.getVar('BBPATH', True))
+ bbpath = str(self.tinfoil.config_data.getVar('BBPATH'))
self.require_re = re.compile(r"require\s+(.+)")
self.include_re = re.compile(r"include\s+(.+)")
self.inherit_re = re.compile(r"inherit\s+(.+)")
- global_inherit = (self.tinfoil.config_data.getVar('INHERIT', True) or "").split()
+ global_inherit = (self.tinfoil.config_data.getVar('INHERIT') or "").split()
# The bb's DEPENDS and RDEPENDS
for f in pkg_fn: