aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2005-05-28 19:08:00 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2005-05-28 19:08:00 +0000
commitd9f628338e61d9c6621eb0ae96b826c430a8d51e (patch)
tree7afe8d2ec0b6e50484e360f33c71b81caa105d1f /bin
parentadeacca614de465701f395eea644fe7c21673bf4 (diff)
downloadbitbake-d9f628338e61d9c6621eb0ae96b826c430a8d51e.tar.gz
bitbake/bin/bitbake:
update_data() of make.cfg after we've parsed the each and every bitbake file. Call me paranoid but this way we make sure that changes made in the bb files are actually taken...
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake3
1 files changed, 1 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 4adb6d740..482b71ffc 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -637,8 +637,6 @@ class BBCooker:
self.parseConfigurationFile( os.path.join( "conf", "bitbake.conf" ) )
- bb.data.update_data( make.cfg )
-
if not bb.data.getVar("BUILDNAME", make.cfg):
bb.data.setVar("BUILDNAME", os.popen('date +%Y%m%d%H%M').readline().strip(), make.cfg)
@@ -696,6 +694,7 @@ class BBCooker:
print "Requested parsing .bb files only. Exiting."
return
+ bb.data.update_data( make.cfg )
self.buildDepgraph()
if make.options.show_versions: