aboutsummaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2006-05-03 14:31:36 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2006-05-03 14:31:36 +0000
commit8e95431593bf13c2e15ccb1406a1edfdf3e1a290 (patch)
treeb5606f3a9046d3776ad33950556a3b41a472f6b5 /bin
parent93ed727d3900ac350daa47405000f650bd6cce65 (diff)
downloadbitbake-8e95431593bf13c2e15ccb1406a1edfdf3e1a290.tar.gz
bitbake/bin/bitbake:
- Make the update_data for buildDepGraph act on a copy of self.configuration.data fixing certain dependency errors.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake6
1 files changed, 4 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index ac4ec164c..be7b94bc1 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -701,6 +701,9 @@ class BBCooker:
all_depends = self.status.all_depends
pn_provides = self.status.pn_provides
+ localdata = data.createCopy(self.configuration.data)
+ bb.data.update_data(localdata)
+
def calc_bbfile_priority(filename):
for (regex, pri) in self.status.bbfile_config_priorities:
if regex.match(filename):
@@ -708,7 +711,7 @@ class BBCooker:
return 0
# Handle PREFERRED_PROVIDERS
- for p in (bb.data.getVar('PREFERRED_PROVIDERS', self.configuration.data, 1) or "").split():
+ for p in (bb.data.getVar('PREFERRED_PROVIDERS', localdata, 1) or "").split():
(providee, provider) = p.split(':')
if providee in self.preferred and self.preferred[providee] != provider:
bb.error("conflicting preferences for %s: both %s and %s specified" % (providee, provider, self.preferred[providee]))
@@ -906,7 +909,6 @@ class BBCooker:
print "Requested parsing .bb files only. Exiting."
return
- bb.data.update_data( self.configuration.data )
self.buildDepgraph()
if self.configuration.show_versions: