aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:41:10 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:41:10 +0000
commitf4656c121e34af8dcbb22969fd5e7f559288470b (patch)
tree31fe142eceff1dbfd6fd8aad64fff53cca0c7f4d
parentd02bbc17c10a8838fb0b86611e94b91bb1e8fb43 (diff)
downloadbitbake-f4656c121e34af8dcbb22969fd5e7f559288470b.tar.gz
cooker.py: Add parseConfiguration() function and move inheritFromOS call outside the parser and into cooker
-rwxr-xr-xbin/bitbake2
-rw-r--r--lib/bb/cooker.py4
-rw-r--r--lib/bb/parse/parse_py/ConfHandler.py1
3 files changed, 6 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 4492bf045..e262d0b9b 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -113,6 +113,8 @@ Default BBFILES are the .bb files in the current directory.""" )
cooker = bb.cooker.BBCooker(configuration)
+ cooker.parseConfiguration()
+
if configuration.profile:
try:
import cProfile as profile
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 8e6acb19f..50624d8d3 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -59,6 +59,10 @@ class BBCooker:
self.configuration.data = bb.data.init()
+ def parseConfiguration(self):
+
+ bb.data.inheritFromOS(self.configuration.data)
+
for f in self.configuration.file:
self.parseConfigurationFile( f )
diff --git a/lib/bb/parse/parse_py/ConfHandler.py b/lib/bb/parse/parse_py/ConfHandler.py
index e6488bbe1..f8a49689e 100644
--- a/lib/bb/parse/parse_py/ConfHandler.py
+++ b/lib/bb/parse/parse_py/ConfHandler.py
@@ -118,7 +118,6 @@ def handle(fn, data, include = 0):
init(data)
if include == 0:
- bb.data.inheritFromOS(data)
oldfile = None
else:
oldfile = bb.data.getVar('FILE', data)