aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2006-04-29 10:12:12 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2006-04-29 10:12:12 +0000
commit83b652ff904ee0edd8cef15ad51e9853eeb6dee8 (patch)
treefee1a2dc8e9de390dde555e1b42a566edaf0e685
parent481141291a4e6bc0cfb2d6cb22d3c8f0762be43e (diff)
downloadbitbake-83b652ff904ee0edd8cef15ad51e9853eeb6dee8.tar.gz
lib/bb/cache.py:
- Check the directory exists before chdir. Catches the parsing error instead of crashing bitbake.
-rw-r--r--lib/bb/cache.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index e3e0d6a16..921a9f758 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -271,7 +271,8 @@ class Cache:
#data.setVar('TOPDIR', topdir, cfg)
# go there
oldpath = os.path.abspath(os.getcwd())
- os.chdir(topdir)
+ if self.mtime(topdir):
+ os.chdir(topdir)
bb_data = data.init_db(cooker.configuration.data)
try:
parse.handle(bbfile, bb_data) # read .bb data