aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rrdtool
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rrdtool')
-rw-r--r--recipes/rrdtool/perl-make-options.diff12
-rw-r--r--recipes/rrdtool/rrdtool_1.0.49.bb27
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/rrdtool/perl-make-options.diff b/recipes/rrdtool/perl-make-options.diff
new file mode 100644
index 0000000000..5da332f709
--- /dev/null
+++ b/recipes/rrdtool/perl-make-options.diff
@@ -0,0 +1,12 @@
+--- perl-shared/Makefile.PL.in.o 2004-10-27 14:55:36.413765216 +0200
++++ perl-shared/Makefile.PL.in 2004-10-27 14:56:50.447510376 +0200
+@@ -12,6 +12,9 @@
+ 'DEFINE' => "-DPERLPATCHLEVEL=$Config{PATCHLEVEL}",
+ 'INC' => '-I@top_srcdir@ -I@top_srcdir@/src -I@top_srcdir@/gd1.3',
+ 'CCFLAGS' => "$Config{ccflags} -DHAVE_CONFIG_H",
++ 'CC' => '@CC@',
++ 'LD' => '@CC@',
++ 'LDFROM' => '@LDFLAGS@',
+ # where to look for the necessary libraries
+ # Perl will figure out which one is valid
+ 'depend' => {'RRDs.c' => "@top_srcdir@/src/.libs/librrd_private.a"},
diff --git a/recipes/rrdtool/rrdtool_1.0.49.bb b/recipes/rrdtool/rrdtool_1.0.49.bb
new file mode 100644
index 0000000000..11968ea609
--- /dev/null
+++ b/recipes/rrdtool/rrdtool_1.0.49.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "High performance data logging and graphing system for time series data."
+HOMEPAGE = "http://oss.oetiker.ch/rrdtool/"
+SECTION = "utils"
+LICENSE = "GPLv2"
+DEPENDS = "libpng zlib"
+DEPENDS_rddtool-perl = "perl-module-lib perl-module-dynaloader"
+PR = "r2"
+SRC_URI = "http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.0.x/rdtool-${PV}.tar.gz \
+ file://perl-make-options.diff;patch=1;pnum=0"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared --enable-local-libpng --enable-local-zlib --program-prefix=''"
+
+do_install_append() {
+ install -d ${D}${docdir}/rrdtool/
+ mv ${D}/usr/html ${D}${docdir}/rrdtool/
+ mv ${D}/usr/doc/* ${D}${docdir}/rrdtool/
+ mv ${D}/usr/examples ${D}${docdir}/rrdtool/
+ mv ${D}/usr/contrib ${D}${docdir}/rrdtool/
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/perl"