aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rott/rott_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rott/rott_1.0.bb')
-rw-r--r--recipes/rott/rott_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/rott/rott_1.0.bb b/recipes/rott/rott_1.0.bb
new file mode 100644
index 0000000000..e1fc4e6a74
--- /dev/null
+++ b/recipes/rott/rott_1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Rise of the Triad - an SDL based Doom clone - QtE based Palmtop Environments Edition"
+HOMEPAGE = "http://www.icculus.org/root"
+LICENSE = "GPL"
+PR = "r2"
+
+APPIMAGE = "${WORKDIR}/rott.jpg"
+
+SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz \
+ file://gcc4.patch;patch=1;pnum=2 \
+ file://rott.jpg"
+S = "${WORKDIR}/rott-${PV}/rott"
+
+CFLAGS += "-DPLATFORM_UNIX"
+EXTRA_OEMAKE = 'SDL_INC_DIR=${STAGING_INCDIR}/SDL CC="${CC}" EXTRALDFLAGS="${LDFLAGS}"'
+
+inherit sdl
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 rott ${D}${bindir}
+}