aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop/powertop_1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/powertop/powertop_1.8.bb')
-rw-r--r--recipes/powertop/powertop_1.8.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/powertop/powertop_1.8.bb b/recipes/powertop/powertop_1.8.bb
new file mode 100644
index 0000000000..ab84161ddc
--- /dev/null
+++ b/recipes/powertop/powertop_1.8.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.linuxpowertop.org/"
+LICENSE = "GPLv2"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
+
+CFLAGS += "${LDFLAGS}"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}