aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/oprofile/oprofile_0.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/oprofile/oprofile_0.9.5.bb')
-rw-r--r--recipes/oprofile/oprofile_0.9.5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/oprofile/oprofile_0.9.5.bb b/recipes/oprofile/oprofile_0.9.5.bb
new file mode 100644
index 0000000000..d89624000d
--- /dev/null
+++ b/recipes/oprofile/oprofile_0.9.5.bb
@@ -0,0 +1,27 @@
+require oprofile.inc
+
+RDEPENDS += "binutils-symlinks"
+RRECOMMENDS += "kernel-vmlinux"
+PR = "r3"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+ file://acinclude.m4 \
+ "
+
+do_stage () {
+ # As of 0.9.4 there is a libopagent library to compile and link against.
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dev ${PN}-doc ${PN}-dbg ${PN}"
+
+FILES_${PN} += "\
+ ${libdir}/oprofile/libopagent.so.* \
+"
+
+FILES_${PN}-dev += "\
+ ${libdir}/oprofile/lib*.so \
+ ${libdir}/oprofile/lib*.a \
+ ${libdir}/oprofile/lib*.la \
+"