aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-watch/gpe-watch-0.10/fix_install.patch')
-rw-r--r--recipes/gpe-watch/gpe-watch-0.10/fix_install.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch b/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
new file mode 100644
index 0000000000..3ae63a839f
--- /dev/null
+++ b/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
@@ -0,0 +1,13 @@
+diff --git gpe-watch-0.10/Makefile-orig gpe-watch-0.10/Makefile
+index 2f74616..58fa802 100644
+--- gpe-watch-0.10/Makefile-orig
++++ gpe-watch-0.10/Makefile
+@@ -39,7 +39,7 @@ $(PACKAGE): $(OBJS) $(LIB)
+
+ install-program: all $(PACKAGE).desktop
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ #mkdir -p $(DESTDIR)$(PREFIX)/share/$(PACKAGE)