aboutsummaryrefslogtreecommitdiffstats
path: root/conf/distro/obsolete
diff options
context:
space:
mode:
Diffstat (limited to 'conf/distro/obsolete')
-rw-r--r--conf/distro/obsolete/nylon.conf89
-rw-r--r--conf/distro/obsolete/wrt54oe.conf31
2 files changed, 120 insertions, 0 deletions
diff --git a/conf/distro/obsolete/nylon.conf b/conf/distro/obsolete/nylon.conf
new file mode 100644
index 0000000000..6b9d3d968d
--- /dev/null
+++ b/conf/distro/obsolete/nylon.conf
@@ -0,0 +1,89 @@
+#############################################################################
+#@TYPE: Distribution
+#@NAME: Nylon Linux
+#@DESCRIPTION: Distribution configuration for Nylon Mesh Linux distribution
+#############################################################################
+
+require conf/distro/angstrom-2008.1.conf
+
+#############################################################################
+# NAME and VERSION
+#############################################################################
+DISTRO_NAME = "nylon"
+DISTRO = ${DISTRO_NAME}
+DISTRO_VERSION = "${NYLON_VERSION}"
+BUILDNAME := "${NYLON_VERSION}"
+#DISTRO_TYPE = "release"
+DISTRO_TYPE = "debug"
+TARGET_FPU = "soft"
+SRCDATE := "20050527"
+TARGET_VENDOR = "-nylon"
+
+# Ensure some form of release config, so error out if someone thinks he knows better
+DISTRO_CHECK := "${@bb.data.getVar("DISTRO_VERSION",d,1) or bb.fatal('Remove this line or set a dummy DISTRO_VERSION")
+
+#############################################################################
+# PACKAGING
+#############################################################################
+# Chose the packaging system
+INHERIT += "nylon-mirrors"
+IMAGE_FSTYPES ?= "tar.gz jffs2"
+
+#############################################################################
+# IMAGES
+#############################################################################
+# Name the generated images in a sane way
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}_${BUILDNAME}"
+KERNEL_IMAGE_NAME = "kernel-${KERNEL_VERSION}-${MACHINE}_${BUILDNAME}"
+
+#############################################################################
+# KERNEL
+#############################################################################
+KERNEL = "kernel24"
+MACHINE_KERNEL_VERSION = "2.4"
+
+#############################################################################
+# TOOLCHAIN
+#############################################################################
+fixedCxxflags = "${@bb.data.getVar('CXXFLAGS', d, 1).replace('-fvisibility-inlines-hidden','')}"
+CXXFLAGS := ${fixedCxxflags}
+
+# we're not supporting pcmcia right now
+DISTRO_FEATURES = "nfs smbfs wifi pcmcia ppp ext2 vfat usbhost pci"
+
+# FIXME: cannot build linux-libc-headers unless this is set.
+OPKGBUILDCMD = "stage-manager-opkg-build -o 0 -g 0"
+
+#############################################################################
+# PREFERRED VERSIONS
+#############################################################################
+PREFERRED_VERSION_busybox = "1.7.2"
+PREFERRED_VERSION_glibc = "2.3.3"
+PREFERRED_VERSION_glibc-initial = "2.3.2"
+PREFERRED_VERSION_shorewall = "2.0.9-monolithic"
+PREFERRED_VERSION_ppp-dsl = "0.1-monolithic"
+PREFERRED_VERSION_mtd-utils = "1.1.0"
+PREFERRED_VERSION_kismet = "2005-01-R1"
+PREFERRED_VERSION_automake-native = "1.10.2"
+PREFERRED_VERSION_pkgconfig-native = "0.23"
+PREFERRED_VERSION_netperf = "2.3"
+
+PREFERRED_VERSION_gcc-cross-initial = "3.3.4"
+PREFERRED_VERSION_gcc-cross-intermediate = "3.3.4"
+PREFERRED_VERSION_gcc-cross = "3.3.4"
+PREFERRED_VERSION_gcc-cross-sdk = "3.3.4"
+PREFERRED_VERSION_gcc = "3.3.4"
+PREFERRED_VERSION_binutils-cross = "2.14.90.0.7"
+PREFERRED_VERSION_binutils-cross-sdk = "2.14.90.0.7"
+PREFERRED_VERSION_binutils = "2.16"
+PREFERRED_VERSION_linux-libc-headers = "2.6.18"
+PREFERRED_VERSION_prism54-firmware = "1.0.3.0"
+#PREFERRED_VERSION_udev = "089"
+PREFERRED_VERSION_udev = "100"
+PREFERRED_VERSION_madwifi-modules = "0.9.3"
+PREFERRED_VERSION_madwifi-tools = "0.9.3"
+PREFERRED_VERSION_e2fsprogs-libs = "1.41.8"
+PREFERRED_VERSION_dbus = "1.2.1"
+
+PREFERRED_PROVIDER_hotplug = "linux-hotplug"
+PREFERRED_PROVIDER_opkg = "opkg"
diff --git a/conf/distro/obsolete/wrt54oe.conf b/conf/distro/obsolete/wrt54oe.conf
new file mode 100644
index 0000000000..0cea34912a
--- /dev/null
+++ b/conf/distro/obsolete/wrt54oe.conf
@@ -0,0 +1,31 @@
+#@TYPE: Distribution
+#@NAME: WRT54OE Linux
+#@DESCRIPTION: Distribution configuration for the WRT54 Linux
+
+# this distribution is mainly for wireless networking devices and includes
+# packages necessary for wireless LAN access point, routing, encryption and
+# especially mesh routing applications
+#
+# it is primarily aimed at the Linksys WRT54G(S) routers and other
+# mipsel based platforms supported by OpenWRT (we base on their work)
+
+INHERIT += "package_ipk debian"
+
+TARGET_OS = "linux-uclibc"
+LIBC = "uclibc"
+require conf/distro/include/${LIBC}.inc
+
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-intermediate:gcc-cross-intermediate"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
+
+PREFERRED_VERSION_gcc-cross-initial = "3.4.4"
+PREFERRED_VERSION_gcc-cross-intermediate = "3.4.4"
+PREFERRED_VERSION_gcc-cross = "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk = "3.4.4"
+PREFERRED_VERSION_gcc = "3.4.4"
+
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}_${BUILDNAME}"
+KERNEL_IMAGE_NAME = "kernel-${KV}-${MACHINE}_${BUILDNAME}"
+