aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ncurses/ncurses.inc3
-rw-r--r--recipes/ncurses/ncurses_5.4.bb3
-rw-r--r--recipes/zlib/zlib.inc6
3 files changed, 8 insertions, 4 deletions
diff --git a/recipes/ncurses/ncurses.inc b/recipes/ncurses/ncurses.inc
index 3cf6a57e60..bebdeb4cb4 100644
--- a/recipes/ncurses/ncurses.inc
+++ b/recipes/ncurses/ncurses.inc
@@ -32,8 +32,7 @@ export EXTRA_OEMAKE = '"BUILD_LDFLAGS=" "BUILD_CCFLAGS=${BUILD_CCFLAGS}"'
# Below option is added to overcome the GCC bug on ARM
# see http://gcc.gnu.org/PR42981 for further details.
# We could potentially take it off when its fixed in gcc 4.5
-
-CFLAGS_append_arm = " -fforward-propagate "
+CFLAGS_EXTRA_append_arm = " -fforward-progagate"
# This is necessary so that the "tic" command executed during the install can
# link with the correct libary in staging.
diff --git a/recipes/ncurses/ncurses_5.4.bb b/recipes/ncurses/ncurses_5.4.bb
index 50231a0e3e..5726110ff1 100644
--- a/recipes/ncurses/ncurses_5.4.bb
+++ b/recipes/ncurses/ncurses_5.4.bb
@@ -12,7 +12,10 @@ LEAD_SONAME = "libncurses.so.5"
SRC_URI[md5sum] = "069c8880072060373290a4fefff43520"
SRC_URI[sha256sum] = "5abce063cf431790f4e6a801a96c7eea0b33a41ecd0970f6312f52575c083b36"
+CFLAGS += "${CFLAGS_EXTRA}"
BBCLASSEXTEND = "native nativesdk sdk"
+CFLAGS_EXTRA_virtclass-native = ""
+CFLAGS_EXTRA_virtclass-sdk = ""
DEPENDS_virtclass-native = ""
EXTRA_OEMAKE_virtclass-native = '"BUILD_CCFLAGS=${BUILD_CCFLAGS}"'
EXTRA_OEMAKE_virtclass-sdk = '"BUILD_CCFLAGS=${BUILD_CCFLAGS}"'
diff --git a/recipes/zlib/zlib.inc b/recipes/zlib/zlib.inc
index 5b00ccf6e0..5c00acbd3e 100644
--- a/recipes/zlib/zlib.inc
+++ b/recipes/zlib/zlib.inc
@@ -8,8 +8,10 @@ INC_PR ="r7"
# Below option is added to overcome the GCC bug on ARM
# see http://gcc.gnu.org/PR42981 for further details.
# We could potentially take it off when its fixed in gcc 4.5
-
-CFLAGS_append_arm = " -fforward-propagate "
+CFLAGS += "${CFLAGS_EXTRA}"
+CFLAGS_EXTRA_append_arm = " -fforward-propagate"
+CFLAGS_EXTRA_virtclass-native = ""
+CFLAGS_EXTRA_virtclass-sdk = ""
BBCLASSEXTEND = "native sdk"