aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/openomap.conf12
-rw-r--r--conf/machine/omap1510inn.conf0
-rw-r--r--conf/machine/omap1610h2.conf4
-rw-r--r--conf/machine/omap1710h3.conf0
-rw-r--r--conf/machine/omap2420h4.conf0
-rw-r--r--conf/machine/omap5912osk.conf18
-rw-r--r--packages/ipkg/ipkg-0.99.144/paths.patch167
-rw-r--r--packages/ipkg/ipkg_0.99.144.bb2
8 files changed, 201 insertions, 2 deletions
diff --git a/conf/distro/openomap.conf b/conf/distro/openomap.conf
index e69de29bb2..af0f52a4a6 100644
--- a/conf/distro/openomap.conf
+++ b/conf/distro/openomap.conf
@@ -0,0 +1,12 @@
+#@TYPE: Distribution
+#@NAME: OpenOMAP
+#@DESCRIPTION: OE Distribution for TI OMAP Development Boards
+
+INHERIT += " package_ipk debian"
+TARGET_OS ?= "linux-uclibc"
+TARGET_FPU ?= "soft"
+
+# 2.4 vs 2.6 is a distro decision.
+MODUTILS = "26"
+BOOTSTRAP_EXTRA_DEPENDS += "udev"
+BOOTSTRAP_EXTRA_RDEPENDS += "udev"
diff --git a/conf/machine/omap1510inn.conf b/conf/machine/omap1510inn.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/conf/machine/omap1510inn.conf
diff --git a/conf/machine/omap1610h2.conf b/conf/machine/omap1610h2.conf
index 769c08cc70..40aaa2917a 100644
--- a/conf/machine/omap1610h2.conf
+++ b/conf/machine/omap1610h2.conf
@@ -4,13 +4,15 @@
TARGET_ARCH = "arm"
IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
-MODUTILS = "26"
+
BOOTSTRAP_EXTRA_DEPENDS += "virtual/kernel modutils-collateral"
BOOTSTRAP_EXTRA_RDEPENDS += "modutils-collateral"
+SERIAL_CONSOLE ?= "115200 ttyS0"
EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x40000"
include conf/machine/tune-arm926ejs.conf
diff --git a/conf/machine/omap1710h3.conf b/conf/machine/omap1710h3.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/conf/machine/omap1710h3.conf
diff --git a/conf/machine/omap2420h4.conf b/conf/machine/omap2420h4.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/conf/machine/omap2420h4.conf
diff --git a/conf/machine/omap5912osk.conf b/conf/machine/omap5912osk.conf
index e69de29bb2..a01e970665 100644
--- a/conf/machine/omap5912osk.conf
+++ b/conf/machine/omap5912osk.conf
@@ -0,0 +1,18 @@
+#@TYPE: Machine
+#@NAME: OMAP5912 cpu on an OSK board
+#@DESCRIPTION: Machine configuration for the OMAP Starter Kit with a 5912 processor
+
+TARGET_ARCH = "arm"
+IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+
+PREFERRED_PROVIDER_xserver = "xserver-kdrive"
+PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
+PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
+
+BOOTSTRAP_EXTRA_DEPENDS += "virtual/kernel modutils-collateral"
+BOOTSTRAP_EXTRA_RDEPENDS += "modutils-collateral"
+
+SERIAL_CONSOLE ?= "115200 ttyS0"
+EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x40000"
+
+include conf/machine/tune-arm926ejs.conf
diff --git a/packages/ipkg/ipkg-0.99.144/paths.patch b/packages/ipkg/ipkg-0.99.144/paths.patch
index e69de29bb2..df21491cad 100644
--- a/packages/ipkg/ipkg-0.99.144/paths.patch
+++ b/packages/ipkg/ipkg-0.99.144/paths.patch
@@ -0,0 +1,167 @@
+Index: C/ipkg.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ C/ipkg.h 2005-02-25 15:28:24.000000000 -0600
+@@ -0,0 +1,59 @@
++/* ipkg.h - the itsy package management system
++
++ Carl D. Worth
++
++ Copyright (C) 2001 University of Southern California
++
++ This program is free software; you can redistribute it and/or
++ modify it under the terms of the GNU General Public License as
++ published by the Free Software Foundation; either version 2, or (at
++ your option) any later version.
++
++ This program is distributed in the hope that it will be useful, but
++ WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ General Public License for more details.
++*/
++
++#ifndef IPKG_H
++#define IPKG_H
++
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
++#if 0
++#define IPKG_DEBUG_NO_TMP_CLEANUP
++#endif
++
++#include "includes.h"
++#include "ipkg_conf.h"
++#include "ipkg_message.h"
++
++#define IPKG_PKG_EXTENSION ".ipk"
++#define DPKG_PKG_EXTENSION ".deb"
++
++#define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-"
++#define IPKG_PKG_VERSION_SEP_CHAR '_'
++
++#define IPKG_STATE_DIR_PREFIX IPKGDIR
++#define IPKG_LISTS_DIR_SUFFIX "lists"
++#define IPKG_INFO_DIR_SUFFIX "info"
++#define IPKG_STATUS_FILE_SUFFIX "status"
++
++#define IPKG_BACKUP_SUFFIX "-ipkg.backup"
++
++#define IPKG_LIST_DESCRIPTION_LENGTH 128
++
++enum ipkg_error {
++ IPKG_SUCCESS = 0,
++ IPKG_PKG_DEPS_UNSATISFIED,
++ IPKG_PKG_IS_ESSENTIAL,
++ IPKG_PKG_HAS_DEPENDENTS,
++ IPKG_PKG_HAS_NO_CANDIDATE
++};
++typedef enum ipkg_error ipkg_error_t;
++
++extern int ipkg_state_changed;
++
++#endif
+Index: C/configure.ac
+===================================================================
+--- C.orig/configure.ac 2005-02-25 15:27:58.000000000 -0600
++++ C/configure.ac 2005-02-25 15:28:00.000000000 -0600
+@@ -10,6 +10,14 @@
+ test -f $top_builddir/configure && break
+ done
+
++AC_MSG_CHECKING([ipkg data location])
++AC_ARG_WITH(ipkgdir,
++ AS_HELP_STRING([--with-ipkgdir=ARG],
++ [Where to look for plugins (default=${libdir}/ipkg)]),
++ [ipkgdir=$withval],
++ [ipkgdir='${libdir}/ipkg'])
++AC_MSG_RESULT($ipkgdir)
++AC_SUBST(ipkgdir)
+
+ # Checks for programs
+ AC_PROG_AWK
+@@ -50,4 +58,4 @@
+ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([memmove memset mkdir regcomp strchr strcspn strdup strerror strndup strrchr strstr strtol strtoul sysinfo utime])
+
+-AC_OUTPUT(Makefile etc/Makefile replace/Makefile familiar/Makefile familiar/control familiar/control-unstripped familiar/libipkg-control familiar/libipkg-dev-control libbb/Makefile libipkg.pc ipkg.h)
++AC_OUTPUT(Makefile etc/Makefile replace/Makefile familiar/Makefile familiar/control familiar/control-unstripped familiar/libipkg-control familiar/libipkg-dev-control libbb/Makefile libipkg.pc)
+Index: C/Makefile.am
+===================================================================
+--- C.orig/Makefile.am 2005-02-25 15:27:58.000000000 -0600
++++ C/Makefile.am 2005-02-25 15:28:00.000000000 -0600
+@@ -3,7 +3,8 @@
+
+ HOST_CPU=@host_cpu@
+ BUILD_CPU=@build_cpu@
+-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\"
++ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ \
++ -DLIBDIR=\"$(libdir)\" -DIPKGDIR=\"$(ipkgdir)\"
+
+ bin_PROGRAMS = ipkg-cl
+
+Index: C/ipkg.h.in
+===================================================================
+--- C.orig/ipkg.h.in 2005-02-25 15:27:58.000000000 -0600
++++ /dev/null 1970-01-01 00:00:00.000000000 +0000
+@@ -1,59 +0,0 @@
+-/* ipkg.h - the itsy package management system
+-
+- Carl D. Worth
+-
+- Copyright (C) 2001 University of Southern California
+-
+- This program is free software; you can redistribute it and/or
+- modify it under the terms of the GNU General Public License as
+- published by the Free Software Foundation; either version 2, or (at
+- your option) any later version.
+-
+- This program is distributed in the hope that it will be useful, but
+- WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+- General Public License for more details.
+-*/
+-
+-#ifndef IPKG_H
+-#define IPKG_H
+-
+-#ifdef HAVE_CONFIG_H
+-#include "config.h"
+-#endif
+-
+-#if 0
+-#define IPKG_DEBUG_NO_TMP_CLEANUP
+-#endif
+-
+-#include "includes.h"
+-#include "ipkg_conf.h"
+-#include "ipkg_message.h"
+-
+-#define IPKG_PKG_EXTENSION ".ipk"
+-#define DPKG_PKG_EXTENSION ".deb"
+-
+-#define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-"
+-#define IPKG_PKG_VERSION_SEP_CHAR '_'
+-
+-#define IPKG_STATE_DIR_PREFIX LIBDIR"/ipkg"
+-#define IPKG_LISTS_DIR_SUFFIX "lists"
+-#define IPKG_INFO_DIR_SUFFIX "info"
+-#define IPKG_STATUS_FILE_SUFFIX "status"
+-
+-#define IPKG_BACKUP_SUFFIX "-ipkg.backup"
+-
+-#define IPKG_LIST_DESCRIPTION_LENGTH 128
+-
+-enum ipkg_error {
+- IPKG_SUCCESS = 0,
+- IPKG_PKG_DEPS_UNSATISFIED,
+- IPKG_PKG_IS_ESSENTIAL,
+- IPKG_PKG_HAS_DEPENDENTS,
+- IPKG_PKG_HAS_NO_CANDIDATE
+-};
+-typedef enum ipkg_error ipkg_error_t;
+-
+-extern int ipkg_state_changed;
+-
+-#endif
diff --git a/packages/ipkg/ipkg_0.99.144.bb b/packages/ipkg/ipkg_0.99.144.bb
index 2ddde751cb..0cf93c0401 100644
--- a/packages/ipkg/ipkg_0.99.144.bb
+++ b/packages/ipkg/ipkg_0.99.144.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Itsy Package Manager"
DESCRIPTION_libipkg = "Itsy Package Manager Library"
LICENSE = "GPL"
PROVIDES = "virtual/ipkg libipkg"
-PR = "r1"
+PR = "r2"
PACKAGES =+ "libipkg-dev libipkg"
FILES_libipkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"