aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xcb/libxcb/configure_git.patch20
-rw-r--r--recipes/xcb/libxcb_git.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/xcb/libxcb/configure_git.patch b/recipes/xcb/libxcb/configure_git.patch
new file mode 100644
index 0000000000..5dc9f91129
--- /dev/null
+++ b/recipes/xcb/libxcb/configure_git.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac 2010-06-04 13:45:24.312592212 +0400
++++ b/configure.ac 2010-06-04 13:47:09.468417189 +0400
+@@ -54,7 +54,7 @@
+
+ # Find the xcb-proto protocol descriptions
+ AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
+-XCBPROTO_XCBINCLUDEDIR=`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
++XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR}`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
+ AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
+
+@@ -64,7 +64,7 @@
+
+ # Find the xcbgen Python package
+ AC_MSG_CHECKING(XCBPROTO_XCBPYTHONDIR)
+-XCBPROTO_XCBPYTHONDIR=`$PKG_CONFIG --variable=pythondir xcb-proto`
++XCBPROTO_XCBPYTHONDIR=${STAGING_DIR}`$PKG_CONFIG --variable=pythondir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBPYTHONDIR)
+ AC_SUBST(XCBPROTO_XCBPYTHONDIR)
+
diff --git a/recipes/xcb/libxcb_git.bb b/recipes/xcb/libxcb_git.bb
index 770c18f179..cf728e7817 100644
--- a/recipes/xcb/libxcb_git.bb
+++ b/recipes/xcb/libxcb_git.bb
@@ -7,7 +7,8 @@ PR = "r0"
DEPENDS += "libpthread-stubs"
-SRC_URI = "git://anongit.freedesktop.org/xcb/libxcb;protocol=git"
+SRC_URI = "git://anongit.freedesktop.org/xcb/libxcb;protocol=git \
+ file://configure_git.patch "
S = "${WORKDIR}/git"
PACKAGES =+ "libxcb-xinerama"