aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/libsdl/libsdl-directfb_1.2.9.bb27
1 files changed, 20 insertions, 7 deletions
diff --git a/packages/libsdl/libsdl-directfb_1.2.9.bb b/packages/libsdl/libsdl-directfb_1.2.9.bb
index aa089e0ecb..049ebab93f 100644
--- a/packages/libsdl/libsdl-directfb_1.2.9.bb
+++ b/packages/libsdl/libsdl-directfb_1.2.9.bb
@@ -5,17 +5,27 @@ DEPENDS = "alsa-lib directfb"
PROVIDES = "virtual/libsdl"
LICENSE = "LGPL"
-PR = "r1"
+PR = "r2"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
- file://extra-keys.patch;patch=1 \
- file://directfb_obsolete_calls.patch;patch=1 \
- file://acinclude.m4"
+ file://agawa-piro-mickey-1.2.9.patch;patch=1 \
+ file://pygame-1.2.9.patch;patch=1 \
+ file://mouse-1.2.9.patch;patch=1 \
+ file://kill-stdc++-1.2.9.patch;patch=1 \
+ file://ipaq-1.2.9.patch;patch=1 \
+ file://SDL-Akita-1.2.9.patch;patch=1 \
+ file://fixlibs-1.2.9.patch;patch=1 \
+ file://no-PAGE_SIZE.patch;patch=1 \
+ file://explicit-extern-C.patch;patch=1 \
+ file://acinclude.m4 \
+ file://directfb_obsolete_calls.patch;patch=1"
S = "${WORKDIR}/SDL-${PV}"
inherit autotools binconfig
+CFLAGS_append += " -I${STAGING_INCDIR}/directfb -I${STAGING_INCDIR}/directfb-internal"
+
EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
--enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
--disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
@@ -30,16 +40,19 @@ FILES_${PN}-dev += "${bindir}/*config"
do_configure_prepend() {
rm -f ${S}/acinclude.m4
- cp ${WORKDIR}/acinclude.m4 ${S}/
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ if [ "${PALMTOP_USE_MULTITHREADED_QT}" == "yes" ]
+ then
+ sed -i s,-lqte,-lqte-mt, src/Makefile
+ fi
}
-
do_configure_append () {
cd ${S}
# prevent libtool from linking libs against libstdc++, libgcc, ...
cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
- find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+# find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
}