aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/openobex/files/libusb_crosscompile_check.patch12
-rw-r--r--packages/openobex/openobex_1.2.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/packages/openobex/files/libusb_crosscompile_check.patch b/packages/openobex/files/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..c28921b8ca
--- /dev/null
+++ b/packages/openobex/files/libusb_crosscompile_check.patch
@@ -0,0 +1,12 @@
+diff -Naur openobex-1.2_old/acinclude.m4 openobex-1.2/acinclude.m4
+--- openobex-1.2_old/acinclude.m4 2006-03-07 19:57:49.000000000 +0200
++++ openobex-1.2/acinclude.m4 2006-04-18 23:07:25.000000000 +0300
+@@ -195,7 +195,7 @@
+
+ if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then
+ AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled])
+- AC_CHECK_FILE(${usb_prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb")
++ REQUIRES="libusb"
+ fi
+
+ AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes")
diff --git a/packages/openobex/openobex_1.2.bb b/packages/openobex/openobex_1.2.bb
index 421b342476..97f030d3e2 100644
--- a/packages/openobex/openobex_1.2.bb
+++ b/packages/openobex/openobex_1.2.bb
@@ -8,7 +8,8 @@ LICENSE = "GPL"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
- file://disable-cable-test.patch;patch=1"
+ file://disable-cable-test.patch;patch=1" \
+ file://libusb_crosscompile_check.patch;patch=1"
inherit autotools binconfig pkgconfig