aboutsummaryrefslogtreecommitdiffstats
path: root/rxvt-unicode
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-08-19 23:09:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-08-19 23:09:12 +0000
commit22e77ba48a59472caa780240577c3a7a8846194c (patch)
tree03810d3d074e27be93a5de92d65a3253c076aa64 /rxvt-unicode
parent29d1d42e42307b173fffc97fc6ada5a84eb94e87 (diff)
downloadopenembedded-22e77ba48a59472caa780240577c3a7a8846194c.tar.gz
write patch to make rxvt-unicode 3.7 compile with gcc 3.4.x
BKrev: 41253318xkgeDBkSNVN0y7B3Rb76XA
Diffstat (limited to 'rxvt-unicode')
-rw-r--r--rxvt-unicode/rxvt-unicode-3.7/gcc34.patch0
-rw-r--r--rxvt-unicode/rxvt-unicode_3.7.oe58
2 files changed, 58 insertions, 0 deletions
diff --git a/rxvt-unicode/rxvt-unicode-3.7/gcc34.patch b/rxvt-unicode/rxvt-unicode-3.7/gcc34.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/rxvt-unicode/rxvt-unicode-3.7/gcc34.patch
diff --git a/rxvt-unicode/rxvt-unicode_3.7.oe b/rxvt-unicode/rxvt-unicode_3.7.oe
index e69de29bb2..962a68a78b 100644
--- a/rxvt-unicode/rxvt-unicode_3.7.oe
+++ b/rxvt-unicode/rxvt-unicode_3.7.oe
@@ -0,0 +1,58 @@
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+PR = "r2"
+
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1 \
+ file://gcc34.patch;patch=1"
+
+inherit autotools update-alternatives
+
+# FIXME: silly compile failure with gcc3.4 involving templates
+# don't have the time at the moment to fix. -CL
+BROKEN = "1"
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--disable-menubar --disable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}