aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-04-17 02:15:43 +0200
committerBen Gardiner <bengardiner@nanometrics.ca>2011-08-12 09:22:59 -0400
commit4640c5a8ea8a9a631421903aad157694aa6bd919 (patch)
tree4807e277b109b575c806acda6ef498352d2269af /recipes
parentb8754fb9382e208f669d88858a97e2b77443e58d (diff)
downloadopenembedded-4640c5a8ea8a9a631421903aad157694aa6bd919.tar.gz
mtd-utils: upgrade to latest 1.4.4 release (bugfix)
* whole 1.4.X serie was plagued by mtd alignment bug * http://lists.infradead.org/pipermail/linux-mtd/2011-April/034599.html * (note that now flash_eraseall is just a script) * * utilities are now installed in $sbindir like upstream/debian * change GPLv2 to GPLv2+ (like other distros and oe-core) * switch to BBCLASSEXTEND and customize do install (from oe-core) * remove ARM_INSTRUCTION_SET = "arm" (built fine for armv5te) * keep the split for mkfs.jffs2 and mkfs.ubifs Signed-off-by: Andrea Adami <andrea.adami@gmail.com> (cherry picked from commit f8e1b7793ff5b02fd27ce886b34a57c6c2358239) Tested-by: Ben Gardiner <bengardiner@nanometrics.ca>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/mtd/mtd-utils_1.4.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/mtd/mtd-utils_1.4.4.bb b/recipes/mtd/mtd-utils_1.4.4.bb
new file mode 100644
index 0000000000..19adeff5d5
--- /dev/null
+++ b/recipes/mtd/mtd-utils_1.4.4.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Tools for managing memory technology devices."
+SECTION = "base"
+DEPENDS = "zlib util-linux-ng lzo2"
+#DEPENDS = "zlib lzo e2fsprogs util-linux"
+HOMEPAGE = "http://www.linux-mtd.infradead.org/"
+LICENSE = "GPLv2+"
+PR = "r0"
+
+TAG = "v${PV}"
+
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
+ file://add-exclusion-to-mkfs-jffs2-git-2.patch \
+ "
+
+S = "${WORKDIR}/git/"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'BUILDDIR=${S}'"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
+ install -d ${D}${includedir}/mtd/
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${D}${includedir}/mtd/
+ done
+}
+
+PACKAGES =+ "mkfs-jffs2 mkfs-ubifs"
+FILES_mkfs-jffs2 = "${sbindir}/mkfs.jffs2"
+FILES_mkfs-ubifs = "${sbindir}/mkfs.ubifs"
+
+PARALLEL_MAKE = ""
+
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"