aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-02-16 20:19:07 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-02-17 15:22:10 +0100
commit41d7e2a6eafed92148e9999bd02ca0d862f3eb22 (patch)
tree4c74abb7ed2bd45eb07cb8e040986b8db05e52a9 /recipes
parent473aff453b3793ea80628efa5c54360735b29efe (diff)
downloadopenembedded-41d7e2a6eafed92148e9999bd02ca0d862f3eb22.tar.gz
linux-bug: fix undefined reference to `__gnu_mcount_nc' issue and bump PR
Without that fix we have: LD .tmp_vmlinux1 init/built-in.o: In function `run_init_process': calibrate.c:(.text+0x10): undefined reference to `__gnu_mcount_nc' init/built-in.o: In function `init_post': calibrate.c:(.text+0x3c): undefined reference to `__gnu_mcount_nc' init/built-in.o: In function `do_one_initcall': calibrate.c:(.text+0x148): undefined reference to `__gnu_mcount_nc' init/built-in.o: In function `name_to_dev_t': calibrate.c:(.text+0x2cc): undefined reference to `__gnu_mcount_nc' init/built-in.o: In function `set_reset_devices': calibrate.c:(.init.text+0x10): undefined reference to `__gnu_mcount_nc' init/built-in.o:calibrate.c:(.init.text+0x38): more undefined references to `__gnu_mcount_nc' follow make: *** [.tmp_vmlinux1] Error 1 FATAL: oe_runmake failed Thanks khem in #oe on Freenode on irc for help: Feb 14 19:21:26 <khem> GNUtoo|laptop: are you using profiling [...] Feb 14 19:57:13 <khem> GNUtoo|laptop: ok so here it your problem you are passing -pg Feb 14 19:57:16 <khem> to compiler [...] Feb 14 19:58:11 <khem> GNUtoo|laptop: thats only useful if you will provide mcount and other profiling hook implementation Feb 14 19:58:16 <khem> compiler sort of expects it The solution I chose was to disable the CONFIG_FTRACE that added -pg (profiling compiler option) Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-bug/defconfig10
-rw-r--r--recipes/linux/linux-bug_2.6.27.2.bb2
2 files changed, 4 insertions, 8 deletions
diff --git a/recipes/linux/linux-bug/defconfig b/recipes/linux/linux-bug/defconfig
index 2a82b584f3..66902c5703 100644
--- a/recipes/linux/linux-bug/defconfig
+++ b/recipes/linux/linux-bug/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.27.2
-# Mon Nov 2 11:40:05 2009
+# Mon Feb 14 21:36:04 2011
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1618,7 +1618,6 @@ CONFIG_DEBUG_PREEMPT=y
# CONFIG_LOCK_STAT is not set
# CONFIG_DEBUG_SPINLOCK_SLEEP is not set
# CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set
-CONFIG_STACKTRACE=y
# CONFIG_DEBUG_KOBJECT is not set
CONFIG_DEBUG_BUGVERBOSE=y
# CONFIG_DEBUG_INFO is not set
@@ -1636,14 +1635,11 @@ CONFIG_FRAME_POINTER=y
# CONFIG_SYSCTL_SYSCALL_CHECK is not set
CONFIG_HAVE_FTRACE=y
CONFIG_HAVE_DYNAMIC_FTRACE=y
-CONFIG_TRACING=y
-CONFIG_FTRACE=y
+# CONFIG_FTRACE is not set
# CONFIG_IRQSOFF_TRACER is not set
# CONFIG_PREEMPT_TRACER is not set
# CONFIG_SCHED_TRACER is not set
-CONFIG_CONTEXT_SWITCH_TRACER=y
-CONFIG_FTRACE_SELFTEST=y
-CONFIG_FTRACE_STARTUP_TEST=y
+# CONFIG_CONTEXT_SWITCH_TRACER is not set
# CONFIG_SAMPLES is not set
CONFIG_HAVE_ARCH_KGDB=y
# CONFIG_KGDB is not set
diff --git a/recipes/linux/linux-bug_2.6.27.2.bb b/recipes/linux/linux-bug_2.6.27.2.bb
index f075f0a29a..f3bd2c8a4f 100644
--- a/recipes/linux/linux-bug_2.6.27.2.bb
+++ b/recipes/linux/linux-bug_2.6.27.2.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux kernel for bug"
PV_append = "+svnr${SRCREV}"
KV = "2.6.27.2"
-PR = "r33"
+PR = "r34"
COMPATIBLE_MACHINE = "bug"