aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zgscore
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zgscore
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zgscore')
-rw-r--r--recipes/zgscore/files/qtopia17.patch25
-rw-r--r--recipes/zgscore/zgscore_1.0.2.bb23
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes/zgscore/files/qtopia17.patch b/recipes/zgscore/files/qtopia17.patch
new file mode 100644
index 0000000000..7741ca51a5
--- /dev/null
+++ b/recipes/zgscore/files/qtopia17.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zgscore-src/zgscore_main.cpp~qtopia17 2004-04-07 16:22:03.000000000 +0200
++++ zgscore-src/zgscore_main.cpp 2004-04-08 16:34:31.000000000 +0200
+@@ -1,5 +1,15 @@
+ #include "zgscore.h"
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zgs", ZGS)
+-QTOPIA_MAIN
++//QTOPIA_ADD_APPLICATION("zgs", ZGS)
++//QTOPIA_MAIN
++
++int main(int argc, char** argv)
++{
++ QPEApplication a( argc, argv );
++ ZGS* zgs = new ZGS();
++ a.showMainWidget( zgs );
++ a.exec();
++}
++
++
diff --git a/recipes/zgscore/zgscore_1.0.2.bb b/recipes/zgscore/zgscore_1.0.2.bb
new file mode 100644
index 0000000000..967791e53f
--- /dev/null
+++ b/recipes/zgscore/zgscore_1.0.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Zaurus Golf Score Application for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://nuke.cinlug.org/modules/Static_Docs/data/db/zgs/"
+PR = "r0"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zgs/zgscore_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch;patch=1"
+S = "${WORKDIR}/zgscore-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ install -m 0755 zgscore ${D}${palmtopdir}/bin/zgscore
+ install -m 0755 zgscore.png ${D}${palmtopdir}/pics/
+ install -m 0644 zgscore.desktop ${D}${palmtopdir}/apps/Applications/
+}