aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zbedic
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zbedic
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zbedic')
-rw-r--r--recipes/zbedic/libbedic_1.1.bb42
-rw-r--r--recipes/zbedic/zbedic/opie-icons.patch14
-rw-r--r--recipes/zbedic/zbedic/qtopia17.patch21
-rw-r--r--recipes/zbedic/zbedic_1.2.bb45
4 files changed, 122 insertions, 0 deletions
diff --git a/recipes/zbedic/libbedic_1.1.bb b/recipes/zbedic/libbedic_1.1.bb
new file mode 100644
index 0000000000..9d2193d4ee
--- /dev/null
+++ b/recipes/zbedic/libbedic_1.1.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Library to handle bedic dictionary"
+HOMEPAGE = "http://bedic.sourceforge.net/"
+AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite3"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/zbedic/misc"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/libbedic_${PV}-0.tgz"
+
+S = "${WORKDIR}"
+
+inherit palmtop
+# need to override this, because bedic contains exception handling
+# pass VERSION as a string \\"${PV}.0\\"
+export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS} -DVERSION=\\"${PV}.0\\""
+
+do_configure() {
+ qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib CONFIG+=sharedlib -after \
+ TARGET=bedic \
+ SOURCES-=src/xerox.cpp OBJECTS-=xerox.o \
+ SOURCES-=src/mkbedic.cpp OBJECTS-=mkbedic.o \
+ SOURCES-=src/test_dynamic_dictionary.cpp \
+}
+
+do_install() {
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/include/*.h ${D}${includedir}
+ install -d ${D}${libdir}
+ oe_libinstall -a libbedic ${D}${libdir}
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libbedic/
+ install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/libbedic/
+ oe_libinstall -a libbedic ${STAGING_LIBDIR}
+}
+
+FILES_${PN}-dev = "${includedir} ${libdir}"
diff --git a/recipes/zbedic/zbedic/opie-icons.patch b/recipes/zbedic/zbedic/opie-icons.patch
new file mode 100644
index 0000000000..cd320b3b1d
--- /dev/null
+++ b/recipes/zbedic/zbedic/opie-icons.patch
@@ -0,0 +1,14 @@
+--- zbedic/src/zbedic.cpp.old 2008-09-20 14:36:24.000000000 -0500
++++ zbedic/src/zbedic.cpp 2008-09-20 14:37:21.000000000 -0500
+@@ -142,9 +142,9 @@ ZBEDic::ZBEDic(QWidget *parent, const ch
+ action[TB_SwitchDictionaries] = createAction( tr( "Switch dictionaries" ), "zbedic/switch_dictionary",
+ SLOT(switchToPreviousDict()), CTRL+Key_S );
+ action[TB_ShowHistory] = createAction( tr( "Show history" ), "zbedic/history", SLOT(showHistoryPopup()), CTRL+Key_H );
+- action[TB_Back] = createAction( tr( "Go back" ), "zbedic/back",
++ action[TB_Back] = createAction( tr( "Go back" ), "back",
+ SLOT(navigationPrevious()), Key_End );
+- action[TB_Forward] = createAction( tr( "Go forward" ), "zbedic/forward",
++ action[TB_Forward] = createAction( tr( "Go forward" ), "forward",
+ SLOT(navigationNext()), Key_Home );
+ action[TB_LookupSelection] = createAction( tr( "Lookup selection" ), "zbedic/lookup_selection",
+ SLOT(lookupSelection()), CTRL+Key_L );
diff --git a/recipes/zbedic/zbedic/qtopia17.patch b/recipes/zbedic/zbedic/qtopia17.patch
new file mode 100644
index 0000000000..749fde2c7e
--- /dev/null
+++ b/recipes/zbedic/zbedic/qtopia17.patch
@@ -0,0 +1,21 @@
+--- zbedic/src/main.cpp.old 2008-09-20 14:40:57.000000000 -0500
++++ zbedic/src/main.cpp 2008-09-20 14:51:11.000000000 -0500
+@@ -48,8 +48,16 @@ int main( int argc, char **argv )
+
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zbedic", ZBEDic)
+-QTOPIA_MAIN
++int main(int argc, char** argv)
++{
++ QPEApplication app( argc, argv );
++
++ ZBEDic mainWindow( NULL, NULL );
++ app.setMainWidget( &mainWindow );
++
++ mainWindow.show();
++ return app.exec();
++}
+
+ #endif
+
diff --git a/recipes/zbedic/zbedic_1.2.bb b/recipes/zbedic/zbedic_1.2.bb
new file mode 100644
index 0000000000..61348c32f2
--- /dev/null
+++ b/recipes/zbedic/zbedic_1.2.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "A dictionary application for Qt/E based Palmtop Environments"
+HOMEPAGE = "http://bedic.sourceforge.net/"
+AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libbedic"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/misc"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/zbedic_${PV}-2.tgz \
+ file://opie-icons.patch;patch=1 \
+ file://qtopia17.patch;patch=1"
+
+S = "${WORKDIR}"
+
+inherit opie
+export OE_QMAKE_LINK="${CXX}"
+export OE_QMAKE_CXXFLAGS=" -DVERSION=\\"${PV}.2\\" -DPREFIX_PATH=\\"/usr\\""
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/libbedic LIBS+=-lbedic LIBS+=-lsqlite3 TARGET=zbedic"
+
+do_configure_prepend() {
+ rm -f Makefile
+ qmake -project
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/zbedic/
+ install -d ${D}${palmtopdir}/help/html/
+ # we copy small icons - in other way QVGA users will complain
+ install -m 0644 ${S}/misc/small_icons/*.png ${D}${palmtopdir}/pics/zbedic/
+ install -m 0644 ${S}/misc/large_icons/zbedic.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}/doc/manual/*.html ${D}${palmtopdir}/help/html/
+ rm ${D}${palmtopdir}/pics/zbedic/zbedic.png
+
+ # those ones are taken from OPIE so they have proper size (depend on device)
+ rm ${D}${palmtopdir}/pics/zbedic/back.png
+ rm ${D}${palmtopdir}/pics/zbedic/forward.png
+}
+
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN} ${PN}-dev"
+
+FILES_${PN}-doc += "${palmtopdir}/help"